Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Напишите пожалуйста программу для того, чтобы:

10-11 класс

1) Найти сумму нечетных чисел в интервале от 1 до 20
2) Найти сумму четных чисел в интервале от 1 до 20

Vladkravcov97 02 июня 2014 г., 15:00:38 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ivan997
02 июня 2014 г., 17:41:45 (9 лет назад)

program gt;
var i,s1,s2:integer;
begin
for i:=1 to 20 do
begin
if(i mod 2=1)then s1:=s1+i else s2:=s2+i;
end;
writeln('сумма не чётных чисел на интервале от 1 до 20 ',s1);
writeln('сумма чётных чисел на интервале от 1 до 20 ',s2);
end.

Ответить

Читайте также

1) Напишите пожалуйста программу (на языке BASIC) вычисления по длинам двух сторон треугольника и углу между ними длины третьей стороны и двух других

углов.
2)
Напишите пожалуйста программу (на языке BASIC) для определения подобия:
а) двух прямоугольников по двум смежным сторонам;
б) двух треугольников по трем сторонам.

Петя любит есть вареные яйца.Для того, чтобы приготовить яйцо в смятку нужно варить его Х минут. Чтобы приготовить яйцо вкрутую, нужно сначала приготовить

его всмятку, а потом варить его У минут. Петя любит есть яйцо, когда оно наполовину приготовлено вкрутую, т.е.когда яйцо сначала приготовлено всмятку, а потом прошла еще половина времени, необходимого для того, чтобы это яйцо стало приготовленым вкрутую. Найдите, сколько минут Пете нужно варить яйцо. (1менше или равна Х, У меньше или равен 10 в восемнадцатой степени) Написать программу на Паскаль

Старик Хоттабыч взялся помочь своим друзьям сдать экзамены. Для того, чтобы наколдовать правильный ответ на один вопрос по географии, он должен вырвать из

своей бороды 6 волосков, чтобы наколдовать правильный ответ на один вопрос по математике – 10 волосков, правильный ответ на один вопрос по русскому языку – 8 волосков. Вольке-ибн-Алеше досталось: на экзамене по географии – З вопроса, на экзамене по математике – 5 вопросов, на экзамене по русскому языку – 2 вопроса.
Женьке досталось: на экзамене по географии – 4 вопроса, на экзамене по математике – З вопроса, на экзамене по русскому языку – 4 вопроса.
Гоге-Пилюле досталось: на экзамене по географии – 2 вопроса, на экзамене по математике – 4 вопроса, на экзамене по русскому языку – 5 вопросов.
И, наконец, самому Хоттабычу: на экзамене по географии – 5 вопросов, на экзамене по математике – 2 вопроса, на экзамене по русскому языку – З вопроса.
Сколько волосков пришлось вырвать Хоттабьтчу из своей бороды для того, чтобы помочь каждому из своих друзей (и себе самому тоже); сколько волосков пошло на сдачу экзаменов по каждому из предметов?

Помогите, пожалуйста, решить задачи.

1. В один из жарких летних дней Петя и его друг Вася решили купить арбуз. Они выбрали самый большой и самый спелый, на их взгляд. После недолгой процедуры взвешивания весы показали w килограмм. Поспешно прибежав домой, изнемогая от жажды, ребята начали делить приобретенную ягоду, однако перед ними встала нелегкая задача. Петя и Вася являются большими поклонниками четных чисел, поэтому хотят поделить арбуз так, чтобы доля каждого весила именно четное число килограмм, при этом не обязательно, чтобы доли были равными по величине. Ребята очень сильно устали и хотят скорее приступить к трапезе, поэтому Вы должны подсказать им, удастся ли поделить арбуз, учитывая их пожелание. Разумеется, каждому должен достаться кусок положительного веса.
Входные данные
В первой и единственной строке входных данных записано целое число w (1 ≤ w ≤ 100) — вес купленного ребятами арбуза.
Выходные данные
Выведите YES, если ребята смогут поделить арбуз на две части, каждая из которых весит четное число килограмм, и NO в противном случае.
Примечание
Например, ребята могут поделить арбуз на две части размерами 2 и 6 килограммов соответственно (другой вариант — две части 4 и 4 килограмма).

2. На клетчатой плоскости заданы координаты K зданий. Требуется построить кольцевую дорогу вокруг зданий минимальной длины в виде прямоугольника, со сторонами, параллельными линиям сетки.
Входные данные
Во входном файле, на первой строке, находится число K( ). На следующих K строках находятся пары чисел и – координаты зданий
( ).
Выходные данные
Выведите в выходной файл координаты левого нижнего и правого верхнего углов прямоугольника.

3. Хакер Иван является сотрудником крупной антивирусной компании. Один из вирусов исследованием, которого он занимается, был специально создан для атаки на программы биржевой торговли.
Для того что бы победить зловред Ване необходимо разработать алгоритм, который бы вычислил минимальное количество операций необходимых для того что бы пара чисел (a, b) стала "k -красивой". Пара чисел (a, b) называется "k-красивой" если хотя бы одно из чисел парны не меньше заданного целого числа k. При этом, операции, проводимые с парой чисел (a, b) могут быть только такие:
1. Пара (a, b) может быть преобразована в (a+b, b);
2. Пара (a, b) может быть преобразована в (a, b+a).
Помогите Ване победить.
Входные данные
Единственная строка входных данных содержит три целых числа a, b и k ( - 1018 ≤ x, y, m ≤ 1018).
Выходные данные
Выведите минимальное количество операций или число -1, если сделать заданную пару "k-красивой" невозможно.

4. Инженер-программист Надежда занимается разработкой компилятора для нового сверх секретного языка программирования. Для того чтобы закончить разработку одного из модулей ей остается решить задачу следующего содержания:
Во входных данных Надя получает строку содержащую в себе цифры и скобки одного вида: '(' и ')'. Наде необходимо написать программу, которая для любых входных данных определяет является ли содержащаяся в них скобочная последовательность правильной, и в случае правильности скобочной последовательности возвращает количество встречающихся в ней скобок, если же последовательность неправильная, то выводится число -1.
Скобочная последовательность называется правильной, если:
1. Пустая строка — правильная скобочная последовательность;
2. Правильная скобочная последовательность, взятая в скобки одного типа — правильная скобочная последовательность;
3. Правильная скобочная последовательность, к которой приписана слева или справа правильная скобочная последовательность — тоже правильная скобочная последовательность.
Помогите Наде в разработке компилятора для нового сверх секретного языка программирования.
Входные данные
Единственная строка конечной длины содержит цифры и скобки, длина строки не больше 1024 символов.
Выходные данные
Выведите количество скобок если скобочная последовательность правильная или число -1 если нет.

5. Маленький Вася научился считать сумму цифр для любого числа. Для любого числа, он считал сумму его цифр, затем тоже самое он делал с полученным в результате числом и так далее. Определите сколько раз Васе необходимо посчитать сумму, чтобы она стала цифрой.
Входные данные
Одна непустая строка с числом (0 Выходные данные
Одна строка, с числом.



Вы находитесь на странице вопроса "Напишите пожалуйста программу для того, чтобы:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.