Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

помогите решить пожалуйста, учитель бьется цветочком!

5-9 класс

Составьте программу вычисления количества трехзначных чисел-палиндромов(чисел, которые читаются одинаково слева направо и справа налево).

Ynka0101 25 окт. 2013 г., 19:32:43 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Aygulka001
25 окт. 2013 г., 20:21:02 (10 лет назад)

uses crt;
var e,d,s,i,k:integer;
begin
k:=0;
for i:=100 to 999 do
begin
e:=i mod 10;
d:=(i div 10)mod 10;
s:=i div 100;
if (e=s) or ((e=d) and (e=s)) then inc(k);
end;
writeln(k);
end.


Ответить

Другие вопросы из категории

Помогите СРОЧНО,нужно написать какие программы в компьюторе мне нра...

Какими программами я люблю пользоваться.....
Например: Я люблю слушать музыку в проигрователе AIMP3.....
Надо буквально 5-6 предложений....И программ примерно 3-4.....
ПОМОГИТЕ.....Зарание БОЛЬШОЕ спасибо*)

Паскаль шифр цезаря

почему при дешифровке в слове с буквой "в" в результате выдаёт восклицательный знак то есть не может его дешифровать?




program SHIFR_CEZERYA;
uses crt;
var a,b,c:string;
i,j,k,d,g:integer;
begin
clrscr;
writeln('Шифрование?1-да,0-нет');
readln(g);
writeln('Исходный текст ');
readln(a);
writeln('ключ');
readln(d);
c:=''; //Результат
b:='абвгдеёжзийклмнопрстуфхцчшщъыьэюя';
for i:=1 to length(a) do //цикл
for j:=1 to length(b) do
begin
If g=1 then k:=(j+d) mod 33 else k:=(j-d)mod 33;
If k>33 then k:=k-33;
if k<0 then k:=k+33;
if a[i]=b[j] then c:=c+b[k];
end;
writeln(c);
readkey;
end.

Проведите наблюдения за погодой в своем населенном пункте в течение полного месяца. Результаты наблюдений занесите в таблицу. Дата

Температура, °С
Давление, мм рт. ст.
Направление ветра
Облачность
1












2












3












4












5












6












7












8












9












10












11












12












13












14












15












16












17












18












19












20












21












22












23












24












25












26












27












28












29












30












31












Для визуализации полученных данных постройте:

Читайте также

Помогите решить пожалуйста. линейные массивы.

1.Замена.- переписать линейныймассив вещественных чисел b(30) в обратном порядке.

Три подруги вышли на прогулку в туфлях и платьях белого, зеленого и синего

цветов. Известно, что только у Ани цвета платья и туфель совпадают. Ни туфли,
ни платье Вали не белые. Наташа в зеленых туфлях. Определите цвет платья и
туфель каждой из подруг.
Помогите решить пожалуйста(спасибо)

ПОМОГИТЕ РЕШИТЬ ПОЖАЛУЙСТА! Заданы массивы A и B чисел (N=10) случайным образом. Сформировать новый массив, каждый элемент которого равен:

сумме этих массивов ; минимальную из соответствующих элементов этих массивов.

помогите решить Пожалуйста


Вы находитесь на странице вопроса "помогите решить пожалуйста, учитель бьется цветочком!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.