Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Ребят, спасайте, надо задачку решить на C#. Дано число D (> 0). Последовательность чисел AN определяется следующим образом:

10-11 класс

A1 = 1, A2 = 2, AN = (AN–2+ AN–1)/2, N = 3, 4, ... Найти первый из номеров K, для которых выполняется условие |AK AK–1| < D, и вывести этот номер, а также числа AK–1 и AK.

Если не трудно, то пожалуйста с комментариями/обьяснениями!

RusT2709 25 июля 2013 г., 5:07:21 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Igorekmakarov1
25 июля 2013 г., 7:19:11 (10 лет назад)

// не совсем понял условие по которому оперделяется нужный индекс

// мне показалось, что это умножение, если не так, то сам исправишь условие

// выхода из цикла

 

using System;

namespace ConsoleApplicationTest
{
    class Program
    {
        static void Main(string[] args)
        {
            double A_1 = 1;
            double A_2 = 2;
            double A_3 = (A_1 + A_2) / 2;
            Console.Write("D = ");
            double D = double.Parse(Console.ReadLine());
            int k = 3;
            while (Math.Abs(A_3 * A_2) >= D)
            {
                A_1 = A_2;
                A_2 = A_3;
                A_3 = (A_1 + A_2) / 2;
                k++;
            }
            Console.WriteLine("k = {0}; Ak-1 = {1}; Ak = {2}", k, A_2, A_3);
            Console.ReadLine();
        }
    }
}

Ответить

Читайте также

1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.

Автоматическое устройство имеет 2 кнопки и экран. При включении на экране загорается число 0. При нажатии на одну кнопку число на экране удваивается (вмест

о x появляется 2x). При нажатии на другую кнопку число увеличивается на 1 (вместо x появляется x+1). Как надо нажимать на кнопки, чтобы на экране появилось
a) Число 5
b) Число 99
c) Число 99,если разрешается нажимать на кнопки не более 10 раз?



Вы находитесь на странице вопроса "Ребят, спасайте, надо задачку решить на C#. Дано число D (&gt; 0). Последовательность чисел AN определяется следующим образом:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.