Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Составить программу Плиз, в среде PASCAL ABC (TURBO PASCAL) выполняющую вычисления по формуле:

10-11 класс

y=2ctg3x- \frac{lncosX}{ln(1+ x^{2} )}

Sand555 17 мая 2014 г., 18:08:29 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
200331
17 мая 2014 г., 18:53:36 (9 лет назад)

во вложении
--------------------

+ 0 -
Yura006
17 мая 2014 г., 19:30:04 (9 лет назад)

Паскаль авс:

Program Ikiru;
uses crt;
var
  y,x:real;
begin
  writeln('*** Alphaeus is thinking... ***');
  writeln('***          OK             ***');
  writeln(); writeln();
    write('Введите Х '); readln(x);
    if (sin(3*x)=0) or (ln(1+x*x)=0) or (cos(x)<=0)
      then
        writeln('Функция Y для этого значения Х не определена')
      else
        begin
          y:=2*(cos(3*x)/sin(3*x))-ln(cos(x))/ln(1+x*x);
          writeln('y=',y:8:2);
        end;
end.

Пояснения:
write('Введите Х '); readln(x);
  - программа просит пользователя ввести х
if (sin(3*x)=0) or (ln(1+x*x)=0) or (cos(x)<=0)
  - проверка существования функции (функция ctgХ не существует, если sinX=0, ln берется только от неотрицательных значений, в знаменателе дроби не может быть 0)
Если хотя бы одно из условий не выполняется,  выводится ссобщение о том, что функция для этого значения не определена.
Если все проверки пройдены, программа вычисляет значение функции Y и выводит его на экран.




Ответить

Другие вопросы из категории

Срочно!!!Помогите пожалуйста! Всем известно, что «от перестановки слагаемых сумма не изменяется». Однако, случается и так, что перестановка двух чисел

приводит к более интересным последствиям.

Пусть, например, заданы три числа: a1, a2, a3. Рассмотрим равенство a1+ a2= a3. Оно может быть неверным (например, если a1= 1, a2= 4, a3= 3), однако может стать верным, если поменять некоторые числа местами (например, если поменять местами a2 и a3, оно обратится в равенство 1 + 3 = 4).

Ваша задача – по заданным трем числам определить: можно ли их переставить так, чтобы сумма первых двух равнялась третьему.

Входные данные

Входной файл INPUT.TXT содержит три целых числа: a1, a2, a3 (−108 ≤ a1, a2, a3 ≤ 108).

Выходные данные

В выходной файл OUTPUT.TXT выведите слово «YES», если заданные числа можно переставить так, чтобы сумма первых двух равнялась третьему. В противном случае выведите в выходной файл слово «NO».

Опять-таки нужна программа в среде паскаль



На
вход поступает первое число - колличество чисел в
последовательности.Затем вводится последовательность.Подсчитать сумму
чётных чисел больше 30 в последовательности.

Построить таблицу истинности:

>(A \/ >C) ->(C . B)

К hardwere относят:

1) программное обеспечение
2) схемы ОЗУ
3) архиватор
4)браузер
5)плоттер
6)стример
К software относят:
Печатающее устройства
Сканирующий устройства драйверы
Аппаратное обеспечение утилиты
Программы копировани

Читайте также

Составить программу Плиз, в среде PASCAL ABC (TURBO PASCAL) выполняющую вычисления по формуле:

y=2ctg3x-
распешите все действия что писать плиз.

Составить программу для нахождения наименьшего общего кратного четырех натуральных чисел:по формуле НОК(A,B)=(A*B)/НОД(A*B)

(Определить процедуру, распознающую НОД двух чисел)

Помогите пожалуйста!! ) составить программу в "Pascal abc"!!)

Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h.
Результат представить в виде таблицы, первый столбец которой — значения
аргумента, второй — соответствующие значения функции: "F(x) = 1/2 ctg x/4+4"

В программе Pascal ABC

Помогите составить программы

1. Составить программу для нахождения наибольшего числа из трех чисел.

2. Составить программу для упорядоченное двух элементов по убыванию.



Вы находитесь на странице вопроса "Составить программу Плиз, в среде PASCAL ABC (TURBO PASCAL) выполняющую вычисления по формуле:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.