Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дана последовательность целых чисел, оканчивающаяся числом 100. Определить, есть ли в последовательности число 77. Если такое число есть, то вывести

5-9 класс

«Yes». В противном случае вывести «No». Решить данную задачу двумя способами, используя циклы с пред и пост условиями.

Nuaipov 06 окт. 2014 г., 11:06:19 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vera160369
06 окт. 2014 г., 13:44:38 (9 лет назад)

program spos;
uses crt;
var
numb:array [1..100] of byte; // для последовательности чисел
i,f:integer; //счетчик и переменная в качестве флага
begin
randomize;
f:=0;
for i:=1 to 100 do numb[i]:=random(101);// задает последовательность

for i:=1 to 100 do
begin
write(',',numb[i]); // вывод на экран последовательность(можно удалить)
if (numb[i]=77)then f:=1; // в случае удачной проверки f:=1, в противном останется 0
end;
if f=0 then writeln('Yes') else writeln('No');

end.


program spos;
uses crt;
var
numb:array [1..100] of byte; // для последовательности чисел
i,f:integer; //счетчик и переменная в качестве флага
begin
randomize;
f:=0;
for i:=1 to 100 do begin
numb[i]:=random(101);// задает последовательность
write(' ',numb[i]);//вывод на экран, можно удалить
end;
writeln;
i:=0;
repeat
i:=i+1;
if (numb[i]=77)then f:=1; // в случае удачной проверки f:=1, в противном останется 0
until i<100;
if f=0 then writeln('Yes') else writeln('No');

end.



+ 0 -
Kristinakuzmin2
06 окт. 2014 г., 14:26:12 (9 лет назад)

1)Первый способ:
program one;
var a,b:integer;
begin
b:=0;
readln(a);
while a<>100 do
begin
if a=77 then
begin
b:=b+1;
readln(a);
end
else readln(a);
end;
if b>0 then writeln('Yes')
else writeln('No');
end.
2)Второй способ:
program one;
var a,b:integer;
begin
b:=0;
repeat
readln(a);
if a=77 then b:=b+1;
until a=100;
if b>0 then writeln('Yes')
else writeln('No');
end.

Ответить

Другие вопросы из категории

Хозяин хочет оклеить обоями длинную стену в своем доме. Длина этой стены равна а и

высота б. Рулон обоев имеет длину 12 м и ширину 1 м. Сколько будут стоить обои для всей стены если цена одного рулона к руб.

составьте как можно больше слов из букв : ф, ы, в, а, п, р, о, л, д, ж, э

p.s. буквы могут повторяться

составьте программу которая а)выполняет операцию сцепления трех введенных с клавиатуры символов б)выполняет операцию сцепления трех введенных с

клавиатуры символов и выводит результат сравнения на экран. например 'a'<'б', 'д'='д, 'я'>'ы' в) выполняет сравнение двух введенных с клавиатуры символов и выводит их на экран в порядке вохрастания их кодов

Читайте также

Дана последовательность целых чисел, оканчивающаяся числом 100.

Определить, есть ли в последовательности число 77. Если такое число
есть, то вывести «Yes». В противном случае вывести «No». Решить данную
задачу двумя способами, используя циклы с пред и пост условиями.( в ПАСКАЛЕ)

1. Дано n целых чисел. Вывести все числа, меньшие последнего числа в ряду;

2. Определите, есть ли в массиве числа от 3 до 7. Укажите их номер.






Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающ

ихся 0 или 1.
Программа получает на вход целые числа от -3000 до 3000.

2)Напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3.
НУЖНО СЕГОДНЯ! 66 БАЛЛОВ!

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.



Вы находитесь на странице вопроса "Дана последовательность целых чисел, оканчивающаяся числом 100. Определить, есть ли в последовательности число 77. Если такое число есть, то вывести", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.