Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Заданы числа x, y, z. Если x<0, то P задать как максимальное из x и y; если

10-11 класс

x>0или=0, то P задать как минимальное из y, z.

Ekaterina09043 25 авг. 2013 г., 5:23:17 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
629319
25 авг. 2013 г., 6:50:03 (10 лет назад)

#include<conio.h>

#include<stdio.h>

#include<iostream.h>

 

float Max(float a,float b)

 

 {

      if (a > b) then return a

         else return b;

}

 

float Min(float a,float b)

 {

      if (a < b) then return a

         else return b;

 

int main()

{

     float x,y,z,p;

      clrscr;

      cout<<"Введите 3 числа: ";

      cin>>x;

      cin>>y;

      cin>>z;

      if (z < 0)  p = Max (x, y) 

              else p =Min (x, y);  

    

       cout<<" \nP равно:"<<p<<"\n"; 

       getch();  

 

       return 0; 

 

 

+ 0 -
Юличка2003
25 авг. 2013 г., 8:43:21 (10 лет назад)

var

  x, y, z, p : real;

function max (a, b : real) : real;

begin

 if a > b then max := a else max := b;

end;

function min (a, b : real) : real;

begin

  if a < b then min := a else min := b;

end;

begin

  read (x, y, z);

  if z < 0 then p := max (x, y) else p := min (x, y);

  write (p);

END

 

сами такое же писали на прошлой неделе))училка разбирала)

Ответить

Другие вопросы из категории

Помогите с программами, пожалуйста. Pascal.

1) Из трех, задаваемых с клавиатуры чисел a, b, c, найти сумму наименьшего и наибольшего из этих чисел.

2) Найти среднеарифметическую температуру воздуха за N дней. Число дней и температуру воздуха каждого дня задать самостоятельно.

Читайте также

Ввести с клавиатуры три числа (x,y,z). Если x<y<z, то все числа удвоить.

Если z<y<x, то максимальное число возвести в квадрат. Если числа не
удовлетворяют ни одному из условий – обнулить их.

Определите максимальное число учеников, сдавших экзамен при условии, что: 1. если первый сдал, то и второй сдал; 2. если второй сдал, то третий сдал

или первый не сдал; 3. если четвертый не сдал, то первый сдал, а третий не сдал; 4. если четвертый сдал, то и первый сдал

Даны 2 двузначных целых числа X и y.Найти D=MAX{x+y;y-x}+3,E=MIN{x^2+y^2;y^2+x*y}-4.если D<E,то к переменной D прибавить первую цифру числа

E,иначе из числа взять корень степени, равной второй цифре числа

если есть умеющте напишите,пожалуйста,программу в Паскале

Удвоить трѐхзначное число, введенное с клавиатуры, если оно содержит в своей записи хотя бы одну единицу, и возвести в квадрат в другом случае.

Если введѐнное число не трѐхзначное, вывести сообщение об ошибке.(В ПАСКАЛЕ)

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число



Вы находитесь на странице вопроса "Заданы числа x, y, z. Если x&lt;0, то P задать как максимальное из x и y; если", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.