Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Введите значение x и вычислите значение функции

10-11 класс

f=x*x+5/x-7
Нужно составить программу.Помогите пожалуйста .

кичка 07 янв. 2017 г., 21:10:55 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Maxim07101
07 янв. 2017 г., 23:57:58 (7 лет назад)

var
x,f:integer;
begin
writeln("imput x");
readln(x)
f:=x*x+5/x-7;
writeln(f);

+ 0 -
Marinachibirja
08 янв. 2017 г., 2:09:48 (7 лет назад)

Язык какой?

+ 0 -
Vardanyan242
08 янв. 2017 г., 4:56:36 (7 лет назад)

pascal

Ответить

Другие вопросы из категории

Добрый экзаменатор никогда не ставит двоек по информатике. По причине

своей доброты он заранее определил количество отметок каждого вида и
произвольно расставил их студентам. Причем количество студентов,
которым он не поставил тройку, оказалось равно 27. Количество
информации, содержащееся в сообщении "Студент Иванов не сдал экзамен
на отлично", равно (3 - log27) бит. Информационный объем сообщения
"Абитуриент Сидоров получил четверку" равен двум битам. Чему равно
количество абитуриентов, получивших пятерку?

Даны натуральные

числа m и n.Получить число состоящее из m последних чётных цифр числа n. Написать программу на Паскале только на Паскале.

Читайте также

Напишите программу, которая принимает с клавиатуры числа, пока не будет введено значение 999. Программа должна подсчитать, сколько значений было

введено с клавиатуры (не считая значения 999) и вывести эту информацию на экран.

Program primer_2;

var x,y,z,s:real;
begin
writeln ('Введите значение x');
write('x='); readln(x);
s:=ln(abs(y))+ abs(ln(z));
if x<-2 then y:=2*x;
if -2<=x<=2 then y:=sin(x*e-3)+ln(abs(x));
if x>2 then y:=power((power(cos(sqr(x)),2)+ power(sin(power(x,3)),4)),4);
if x<0 then z:=power(sin(x),2);
if x>=0 then z:=power(e,-(sqr(x+3)));
writeln('Ответ');
writeln('s=',z:8:3);
end.
Ошибка в (if -2<=x<=2 then y:=sin(x*e-3)+ln(abs(x));) пишет что "Операция '<=' не применима к типам integer и boolean"
Кто сможет исправить?



Есть код на паскале, который считает выражение и запрещает ввод букв. Нужно сделать проверку знаменателя на 0 обоих выражений, и вывести текст в случае

нуля

PascalABC

program aip;
var
fltA,fltB,fltB2:real;
code:integer;
function ip(A:real):real;
var A1:string;
begin
write('Введите значение А= ');


//--------
repeat
readln(A1);
val(A1,A,code);
if (code<>0) then writeln('no');
until (A>0);
//-------
ip:=A;
end;
begin
fltA:=ip(fltA);
fltB:= ((1-2*sin(fltA)*sin(fltA))/(1+sin(2*fltA)));
fltB2:= ((1-tan(fltA))/(1+tan(fltA)));
writeln('Первая формула ',fltB:5:5);
writeln('Вторая формула ',fltB2:5:5);
end.



Вы находитесь на странице вопроса "Введите значение x и вычислите значение функции", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.