Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Задание во вложении. Нужно найти ошибки. У меня не определяет, когда одно и два отрицательных. Заранее спасибо)))

10-11 класс

Yanna2001100 09 мая 2013 г., 9:56:47 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vickaazarenko
09 мая 2013 г., 11:24:55 (10 лет назад)

Первое условие неправильно тем, что or не исключает условия, берётся совокупность условий. То есть, если ХОТЯ БЫ одно число будет отрицательным, программа пойдёт по первому условию. Мне кажется, эта программа при вводе трёх отрицательных чисел должна писать сначала "одно отрицательное число", а потом "три отрицательных числа". Думаю, вся проблема лежит именно в первом условии.  Потому что программа всегда будет идти по ней (если, конечно, отрицательные числа есть).

+ 0 -
Алишка888
09 мая 2013 г., 13:14:43 (10 лет назад)

var
    a, b, c: integer;

begin
    write('Введите числа - ');
    read(a, b, c);
    write('Кол-во чисел меньше нуля - ');
    if (a < 0) and (b < 0) and (c < 0) then
        writeln('3')
    else
    if ((a < 0) and (b < 0))
        or ((a < 0) and (c < 0))
        or ((b < 0) and (c < 0)) then
        writeln('2')
    else if (a < 0) or (b < 0) or (c < 0)     then
        writeln('1')
    else
        writeln('0');
end.

Ответить

Другие вопросы из категории

Определить является ли целая часть числа m/n

четной. Если она четная,
то m возвести в квадрат, иначе n утроить.

6. Написать программу для нахождения числа нечетных элементов в массиве из 10 беззнаковых чисел.

7. Написать программу для нахождения числа отрицательных элементов в массиве из 10 знаковых чисел
8. Написать программу для замены всех четных элементов массива из 10 беззнаковых чисел единицами.
9. Написать программу для замены всех нулевых элементов массива из 10 знаковых чисел единицами
10. Написать программу для замены всех троек в массиве из 10 беззнаковых чисел пятерками.

перевести в биты

22 байта
2.перевести в байты
А)15 Кбайт
Б)156Мбайт

3.перевести в килобайт
А)7168 байт
Б)6Мбайт
В)5Гбайт



Вы находитесь на странице вопроса "Задание во вложении. Нужно найти ошибки. У меня не определяет, когда одно и два отрицательных. Заранее спасибо)))", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.