Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Вводится с клавиатуры число Х. Если Х<0, то y=4, если Х=0 то y=2, а если Х<0, то y=х если можно то сразу с дано , контрольным примером,

5-9 класс

блок схема и метод решения

Еваремизова8 29 сент. 2013 г., 22:16:26 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Yunusov563
29 сент. 2013 г., 23:45:02 (10 лет назад)

program vndj;

uses crt;

var x,y:integer;

begin

clrscr;

readln(x);

if x<0 then y:=4;

if x=0 then y:=2;

if x>0 then y:=x;

writeln(y);

readln;

end.

Последние условие скорее всего "x>0", ибо ерунда получается

Блок-схему сам рисуй

 

Ответить

Другие вопросы из категории

Читайте также

Заполните массив с клавиатуры целыми числами и найдите сумму элементов массива с i1-го по i2-й (i1 и i2 вводить с клавиатуры).

Входные данные:
в первой строке целое число n (0 < n ≤ 100) - кол-во элементов в массиве и целые числа i1 и i2 (0 < i1, i2 ≤ 100). Во второй строке целые числа Х1, Х2,..,Хn разделенные пробелом (числа по модулю не превосходят 32000) - значения элементов массива.

Выходные данные:
сумма элементов массива c номерами от i1 до i2.

(Написать программу на Паскале)

1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива.

2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива.
3. Массив из 5 целых чисел вводится с клавиатуры в строку. Найти сумму элементов массива, стоящих на чётных позициях. Вывести исходный массив и полученную сумму.
4. Массив из 40 целых чисел из промежутка [10,90] задается с помощью генератора случайных чисел. Найти сумму элементов массива, кратных n . Вывести исходный массив и полученную сумму.
Помогите кто в чем может.

Язык Паскаль!

1)Вводить с клавиатуры числа, пока не будут введен 0. Найти количество введенных чисел.



Вы находитесь на странице вопроса "Вводится с клавиатуры число Х. Если Х&lt;0, то y=4, если Х=0 то y=2, а если Х&lt;0, то y=х если можно то сразу с дано , контрольным примером,", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.