Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Мыположилив банкSрублей. За годмыполучим P% Используя цикл с условием определить за какой срок сумма вложенных денег увеличится в два раза?

10-11 класс

Reyst95 20 нояб. 2013 г., 4:20:52 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kross111
20 нояб. 2013 г., 6:43:34 (10 лет назад)

program zadacha_bank;
uses crt;
var s,p,i:integer;
       x:real;
begin
clrscr;
readln(s);
readln(p);
x:=s;
i:=0;
While x<s*2 do begin
x:=x+(x/100*i);
i:=i+1;
end;
writeln(i);
end.

+ 0 -
ялимонка
20 нояб. 2013 г., 8:17:01 (10 лет назад)

Program sweta_bank;
uses crt;
var s,p,i:integer;
   x:real;
begin
  write('Введите начальную сумму вклада '); readln(s);
  write('Введите %-ную ставку '); readln(p);
  x:=s;
  i:=0;
  while x<s*2 do begin
    x:=x+(x/100*i*(p/12));
    i:=i+1;
  writeln(x);
  end;
  writeln('При условии ежемесячного начисления процентов по вкладу');
writeln('вклад удвоится через ',i div 12,' лет и ',i mod 12,' месяцев и составит ',x,' рублей');
end.

Ответить

Другие вопросы из категории

Помогите решить пожалуйста!!!! Паскаль!!

Дана квадратная матрица n-го порядка. Найти норму матрицы. Нормой матрицы считать максимум из абсолютных величин ее элементов.

1. Соревнования по плаванию были в самом разгаре, когда стало ясно, что первые четыре места займут мальчики из пятёрки лидеров. Их имена: Валерик, Коля,

Миша, Игорь, Эдик, фамилии: Симаков, Чигрин, Зимин, Копылов, Блинов (имена и фамилии названы в различном порядке). Нашлись знатоки, которые предсказали, что первое место займёт Копылов, второе - Валерик, третье - Чигрин, четвёртое - Эдик. Но ни один из ребят не занял того места, какое ему предсказывали. На самом деле первое место завоевал Миша, второе - Симаков, третье - Коля, четвёртое - Блинов, а Чигрин не попал в четвёрку сильнейших. Назовите имя и фамилию каждого из лидеров.

Средства, реализующие метод защиты информации "Побуждение".

1) программные

2) технические

3) морально-этические

4) организационные

5) законодательные

Читайте также

1)Найдите сумму натуральных нечетных чисел не превышающих n!!!!Это нужно сделать циклом for. 2) Составьте программу,которая производит

суммирование произвольного количества целых чисел вводимых с клавиатуры.Концом последовательности служит ввод отрицательного числа.Программу составьте двумя способами: использую цикл с предусловием и цикл с постусловием

Составление таблицы функции y=a³/(a²+x2) для x , принадлежащих отрезку [-1;1] с шагом 0.1. Так как пример цикла типа for должен быть целочисленным ,

удобнее использовать цикл while, в котором значение x можно изменять при каждом шаге на Dx=0.1

Выбрать правильный ответ. Многократно повторяющаяся часть программы (алгоритма) называется: Циклом; Логическим условием; Оператором;

Ничего из вышеперечисленного.

Бесконечный цикл: Можно остановить путем ввода данных пользователем; Приводит к останову программы Можно использовать для создания короткой паузы в выполнении программы; Приводит к повторению некоторой части программы, пока не будет нажата клавиша “СТОП”.

Можно организовать цикл, повторяющийся до тех пор, пока не выполнится логическое условие с помощью операторов: FOR … NEXT IF… THEN GOTO Все вышеперечисленное.

Содержащаяся одна в другой циклические структуры называются: Вложенными; Простыми; Последовательными; Ничего из вышеперечисленного.

Какая из следующих строк может быть начальной строкой цикла FOR…NEXT: FOR A$=1 TO 15 FOR A=1 TO 15 FOR A=1 TO=15 FOR 4A=1 TO 15

Цикл FOR…NEXT приводит к повторению некоторой части программы, которая носит название: Тело цикла; Глубина цикла; Параметр цикла; Приращение.



Вы находитесь на странице вопроса "Мыположилив банкSрублей. За годмыполучим P% Используя цикл с условием определить за какой срок сумма вложенных денег увеличится в два раза?", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.