Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

19.Вычислить наибольшее и наименьшее значение функции y=3x^2 +x– 4, если на заданном интервале [a,b] x изменяется с шагом 0,1.

10-11 класс

Помогите, пожалуйста, решить задачи в паскале!

Кристина230502 09 дек. 2013 г., 5:13:23 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Raimanchik
09 дек. 2013 г., 6:36:02 (10 лет назад)

19.
Program zadacha;
var   
   a,b,y,mi,ma:real;
begin 
   read(a,b); 
   ma:=3*a*a+a-4; 
   mi:=3*b*b+b-4; 
   while a<=b do begin   
      y:=3*a*a+a-4;   
      a:=a+0.1;   
      if y >= ma then ma := y;   
      if y <= mi then mi := y; 
   end; 
   writeln(mi:10:2); 
   writeln(ma:10:2);  
end.


простые числа:
Program zadacha;
var 
   n,i,j,k:integer;
begin
  read(n);
  for i:=2 to n do begin
    k:=0;
    for j:=1 to i do begin
      if i mod j = 0 then k:=k+1;
    end;
    if k = 2 then writeln(i);
  end;
end.

Ответить

Другие вопросы из категории

Помогите решить пожалуйста!!!! Паскаль!!

Дана квадратная матрица n-го порядка. Найти норму матрицы. Нормой матрицы считать максимум из абсолютных величин ее элементов.

1. Соревнования по плаванию были в самом разгаре, когда стало ясно, что первые четыре места займут мальчики из пятёрки лидеров. Их имена: Валерик, Коля,

Миша, Игорь, Эдик, фамилии: Симаков, Чигрин, Зимин, Копылов, Блинов (имена и фамилии названы в различном порядке). Нашлись знатоки, которые предсказали, что первое место займёт Копылов, второе - Валерик, третье - Чигрин, четвёртое - Эдик. Но ни один из ребят не занял того места, какое ему предсказывали. На самом деле первое место завоевал Миша, второе - Симаков, третье - Коля, четвёртое - Блинов, а Чигрин не попал в четвёрку сильнейших. Назовите имя и фамилию каждого из лидеров.

Читайте также

Найти остаток от деления целой части значения функции y = ln(x²+ab) на 7 и, в зависимости от его величины, напечатать сообщение об одном из дней недели,

пронумеровав их от 0 до 6. Значения переменных а, b, x получить случайным образом на произвольном интервале

помогите решить пожалуйста. по паскалю 1. а) вычисления значения функции у = 7х2 - 3х + 6 при любом значении х;

б) вычисления значения функции х = 12а2 + 7а — 16 при любом значении а.

2.

даны катеты прямоугольного треугольника. Найти его гипотенузу

Помогите мне пожалуйста с программой..(В паскале) Опишите процедуру поиска наибольшего и наименьшего элемента массива. С помощью этой процедуры составить

программу, которая определяет совпадают ли наибольший и наименьший элементы двух массивов A[1..n], B[1..n].

1. написать программу, вычисляющую значение функции y=x-24

2. написать программу, вычисляющую значение функции (y=f(x))
y=x-2, если x>0,
y=0, если x=0,
y=x*x, если x<0



Вы находитесь на странице вопроса "19.Вычислить наибольшее и наименьшее значение функции y=3x^2 +x– 4, если на заданном интервале [a,b] x изменяется с шагом 0,1.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.