Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

написать программу на Паскале: А) Условие задачи №1: если введенное целое число является трехзначным, то удалить из него среднюю цифру; если число

5-9 класс

двухзначное, то удвоить крайние цифры; иначе – выдать сообщение «Ошибка ввода».

Prikolist2015 16 окт. 2016 г., 20:19:33 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
мураа
16 окт. 2016 г., 22:50:13 (7 лет назад)

var
i,x,n:integer;
s1,s2,s3:string;
begin
write('Введите число: ');
readln(x); if (x >999) or (x<10) then write('Ошибка ввода!');
if (x<999) and (x>99) then begin
str(x,s1);
delete(s1,2,1);
write(s1);
end;
if (x<100) and (x>9) then begin
n:= x div 10 *2;
x:=x mod 10 *2;
str(n,s1);
str(x,s2);
s3:=s1+s2;
write(s3);
end;
end.

Ответить

Другие вопросы из категории

В пионерском лагере 70 ребят.Из них 27 занимаются в драмкружке, 32 поют в хоре, 22 увлекаются спортом.В драмкружке 10 ребят из хора, в хоре

6 спортсменов, в драмкружке 8 спортсменов; спортсмена посещают и драмкружок, и хор.
Вопрос:сколько людей не ходят нкуда
Решение пишите обязательно с помощью схемы!
Пожалуйста!!!

сколько секунд минимум потребуется модему, передающему сообщения со скоростью 28800 бит\с, чтобы передать 100 страниц текста в 30 строк по 60 символов

каждая, при условии что каждый символ кодируется одним байтом?
а.50 с
б.6,25 с
в.500 с
г.62,5 с

Читайте также

Помогите написать программу на Паскале.

Напишите программу, которая в последовательности целых чисел
вычисляет сумму всех чисел, которые кратны 6 или 11. Программа получает на вход
целые числа, количество введённых чисел неизвестно, последовательность чисел
заканчивается числом 0 (0 – признак окончания ввода, не входит
в последовательность).

Количество чисел не превышает 1000. Введённые числа по
модулю не превышают 30 000.

Программа должна вывести одно число: сумму всех чисел,
которые кратны 6 или 11.






написать программу в паскале Из диапазона от 10 до 1000 компьютер выбрал случайным образом число. Если выбранное число является трехзначным, то

поменять местами первую и последнюю цифры, выдать на печать число, выбранное ПК и новое, полученное после перестановки цифр. В противном случае, вывести выбранное ПК число

1)найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2)вывести на экран натуральные нечетные числа от 5 до 55.тоже

паскаль 3)найти произведение последовательных натуральных чисел от n до m. написать программу паскаль. 4)найти сумму последовательных натуральных чисел от 10 до 15.тоже паскаль



Вы находитесь на странице вопроса "написать программу на Паскале: А) Условие задачи №1: если введенное целое число является трехзначным, то удалить из него среднюю цифру; если число", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.