Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите решить 1 и 2 пожалуйста

5-9 класс

Pashaev007 14 апр. 2014 г., 1:15:03 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
плоьеп
14 апр. 2014 г., 2:06:09 (10 лет назад)

1)

 

const n = 30;
var
  i, count, s, a: integer;
begin
  for i := 1 to n do begin
    a := 2 + random(4);
    write(a, ' ');
    if(a > 3) then inc(count);
    s := s + a;
  end;
  writeln;
  writeln('Средний балл: ', (s / n):0:2);
  writeln('Кол-во учеников получивших балл выше среднего: ', count);
end.

 

2)

 

const n = 50;
var
  i, count, pp, max, s: integer;
begin
  for i := 1 to n do begin
    pp := 20 + random(81);
    write(pp, ' ');
    if(pp > max) then begin
      max := pp;
      count := i;
    end;
    s := s + pp;
  end;
  writeln;
  writeln('Всего жителей в населенном пункте: ', s);
  writeln('Дом, в котором проживает больше всего людей: ', count);
end.

Ответить

Другие вопросы из категории

5 байт= _________ бит

8 килобайт=___________ байт
1 мегабайт=________байт
88 бит=________ байт
5120 терабайт =_________ гигабай

1. Когда и кем были изобретены счетно-перфорационные машины? Какие задачи на них решались?

2. Что такое электромеханическое реле? Когда создавались релейные вычислительные машины? Каким быстродействием они обладали?
3. Где и когда была построена первая ЭВМ? Как она называлась?
4. Какова роль Джона фон Неймана в создании ЭВМ?
5. Кто был конструктором первых отечественных ЭВМ?
6. На какой элементной базе создавались машины первого поколения? Каковы были их основные характеристики?
7. На какой элементной базе создавались машины второго поколения? В чем их преимущества по сравнению с первым поколением ЭВМ?
8. Что такое интегральная схема? Когда были созданы первые ЭВМ на интегральных схемах? Как они назывались?
9. Какие новые области применения ЭВМ возникли с появлением машин третьего поколения?
10. Что такое микропроцессор? Когда и где был создан первый микропроцессор?
11. Что такое микроЭВМ и персональный компьютер?
12. Какие типы ПК наиболее распространены в мире?
13. Что такое суперкомпьютер?
14. Что такое кластерные системы ПК?
15. В чем особенность компьютеров пятого поколения?

постройте отрицания следующих высказываний

неверно, что число 3 не является делителем числа 198

помогите!нужно решить до завтра.завтра последний день сдачи индивидуальной работы. «Программирование» 9 класс Задание №1 записать по правилам

изучаемого языка программирования следующие выражения:γ m1m2/r^2 Задание 2 «Вычисления по известным формулам». Написать программу:Найти площадь трапеции по известным основаниям и высоте. Задание №3 «Выделение цифр в записи числа» Написать программу:Дано трехзначное число. Верно ли, что оно заканчивается цифрой 7? Задание №4 «Условный оператор» Написать программу:Даны два целых числа. Составить программу, которая большее число возводит в квадрат, а меньшее увеличивает на 10. Если числа равны, то вывести сообщение «ЧИСЛА РАВНЫ». Задание №5 «Циклы» Написать программу:Напишите программу, которая на отрезке от а до в, выводит на экран все четные числа, оканчивающихся нулем.

Читайте также

Помогите решить задачи по информатике, пожалуйста !

1) Имеются два кувшина емкостью 3л и 8л. Напишите алгоритм , выполняя который можно набрать из реки 7л воды. ( разрешается пользоваться только этими кувшинами).
2) Разведывательный дозор в составе двух человек подошел к реке. Мост был разрушен а река слишком глубока и широка чтобы переправиться через нее вброд или вплавь. К счастью около берега в маленькой лодке проплывали два мальчика. Как переправиться на этой лодке через реку если она может выдержать либо одного взрослого либо двух мальчиков?



Вы находитесь на странице вопроса "Помогите решить 1 и 2 пожалуйста", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.