Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Составить алгоритм вычисления площади треугольника по трем заданным сторонам с проверкой на существующий данный треугольник(по формуле Герона)

5-9 класс

Ksuuuuush 26 апр. 2015 г., 4:25:56 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
081167
26 апр. 2015 г., 5:41:33 (8 лет назад)

Паскаль
var a,b,c,S,p:real;
label e;
begin
e: a:=0;b:=0;c:=0;read (a,b,c);
if ((a+b) <= c) or ((a+c) <= b) or ((b+c) <= a) then
begin
writeln ('Такого треугольника не существует, введите стороны заново');
goto e;
end;
if ((a+b) > c) or ((a+c) > b) or ((b+c) > a) then
begin
p:=(a+b+c)/2;
S:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln ('Площадь треугольника = ',S);
end;
end.

+ 0 -
BADMAEVAVERA
26 апр. 2015 г., 8:19:47 (8 лет назад)

Комментарий удален

+ 0 -
KoshkaRu
26 апр. 2015 г., 10:13:32 (8 лет назад)

Вроде того

+ 0 -
Snayper7878
26 апр. 2015 г., 11:42:04 (8 лет назад)

Комментарий удален

+ 0 -
Krustua
26 апр. 2015 г., 12:54:17 (8 лет назад)

на любом

Ответить

Читайте также

1. Составьте блок-схему алгоритма и программу вычисления площади треугольника по трем сторонам. 2. Составьте программу вычисления объема, площади полной

поверхности, суммы ребер прямоугольного параллелепипеда. 3. Составьте программу вычисления диагоналей ромба по стороне и углу.

Составить алгоритм нахождения площади и длины окружности если известен радиус.

Составить алгоритм нахождения площади и длины окружности если известен диаметр.

ребят, помогите пожалуйста, ну ооочень нужно, от этого зависит аттестуют меня или нет, заданий правда много, и пожалуйста, не пишите херню либо очень

мало
эти задания нужно сделать циклами while и for, т е чтобы получилось 12 программ

1. Составьте программу вычисления значения функции: y=7x^2+1/x^2-16
2. Составьте блок-схему алгоритма и программу расположения четырех чисел в порядке возрастания.
3*. Составьте программу, определяющую вид треугольника по трем его сторонам A, B, C.

4. Составьте блок-схему алгоритма и программу вывода на экран всех трехзначных чисел, кратных 7.
5. Составьте блок-схему алгоритма и программу вычисления суммы всех трехзначных чисел, кратных 13.
6*. Составьте программу вывода на экран таблицы степеней 2ⁿ, где 0 ≤ n ≤ 10.

я вас просто умоляю, напишите, пожалуйста



Вы находитесь на странице вопроса "Составить алгоритм вычисления площади треугольника по трем заданным сторонам с проверкой на существующий данный треугольник(по формуле Герона)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.