Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Pascal, Динамические структуры данных.

10-11 класс

Матрица, размещена в динамической памяти

Gipersonic 30 марта 2017 г., 10:33:43 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sport125
30 марта 2017 г., 11:06:10 (7 лет назад)

uses Crt;

type
  MCo = array[1..200] of longint; {строка массива - до 200 столбцов}
  DV = ^MCo; {указатель на строку массива}
  MR = array[1..150] of DV; {массив указателей на строки}

var
  a: MR; {Создается массив указателей на строки}
  n,m:longint;

procedure ShiftCycle(row: longint; k: longint);
var
  i, j, e: longint;
begin
  for i := 1 to k do
  begin
    e := a[row]^[m];
    for j := m - 1 downto 1 do a[row]^[j + 1] := a[row]^[j];
    a[row]^[1] := e
  end;
end;

var
  i, j, e: longint;

begin
  ClrScr;
  writeln('Введите число строк и столбцов массива');
  readln(n,m);
  writeln('Введите элементы массива');
  for i := 1 to n do
  begin
    getmem(a[i], m * sizeof(longint)); {Фактическое выделение памяти под i-ю строку строку массива}
    writeln('Строка ',i,':');
    for j := 1 to m do read(a[i]^[j])
  end;
  writeln;
  for i := 1 to n do
  begin
    ShiftCycle(i, i);
    for j := 1 to m do write(a[i]^[j]:4);
    writeln;
    freemem(a[i], m * sizeof(longint)) {Освобождение памяти из-под i-й строки массива}
  end
end.

Тестовый прогон:

Введите число строк и столбцов массива
4 5
Введите элементы массива
Строка 1:
1 2 3 4 5
Строка 2:
6 7 8 9 10
Строка 3:
11 12 13 14 15
Строка 4:
16 17 18 19 20

    5    1   2    3   4
    9  10   6    7   8
  13  14  15  11  12
  17  18  19  20  16





+ 0 -
Aziz890
30 марта 2017 г., 12:21:10 (7 лет назад)

Комментарий удален

+ 0 -
Женя3324
30 марта 2017 г., 14:18:40 (7 лет назад)

Буду надеяться :)

+ 0 -
Ilseyar83
30 марта 2017 г., 15:57:44 (7 лет назад)

Собственно, в чём суть? Достать некий массив из опер. памяти или создать новый?

+ 0 -
Vasiaaaaa
30 марта 2017 г., 17:59:46 (7 лет назад)

Комментарий удален

+ 0 -
Ksenyaasd11
30 марта 2017 г., 19:30:10 (7 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Физика что такое кинематика ?
Прошу помощи в решении двух задач:

1)Сколько информации содержит в себе сообщение о том, что на поле 4х4 клетки одна из клеток закрашена?

2) В книге 512 страниц. Сколько информации несет сообщение о том, что закладка лежит на какой-либо странице?

Срочно!!! Помогите, пожалуйста, решить задачу. 11 класс

Задание выполняется с помощью среды Delphi: Составить программу, позволяющую получать словесное описание школьных отметок (1-плохо, 2 - неудовлетворительно, 3-удовлетворительно, 4-хорошо, 5-отлично).

Читайте также

Для кодирования номеров автомобилей принята следующая структура данных: Номер региона (двузначное число от 00 до 99), серия (комбинация из трех букв из

набора «А, В, Е, К, М, Н, О, Р, С, Т, У, Х»), номер (трехзначное число от 000 до 999). При создании базы данных автомобильных номеров Петя решил хранить каждый номер в виде массива из 8 символов (два символа на номер региона, три символа на серию и три символа на номер), кодируя каждый символ с помощью однобайтной кодировки ASCII. Вася решил уменьшить объем хранимых данных и принял решение хранить каждый номер в виде трех чисел – одно число для номера региона, одно число для серии (представив все возможные серии в виде натуральных чисел) и одно число для номера. Каждое число Вася будет хранить отдельно, используя для его кодирования минимально возможное число бит. На сколько бит уменьшится объем памяти, необходимый для хранения одного произвольного номера, в варианте кодирования Васи по сравнению с вариантом кодирования Пети? В ответе укажите целое число.

С++. Дана структура «Школьник», имеющая поля: фамилия, имя, пол, дата рождения (год, месяц, число), класс (цифра, буква). Напишите функцию чтения

данных из файла в динамический массив структур. Напишите функцию поиска в динамическом массиве структур количества школьников, двенадцати лет, обучающихся в классах «Б».

1. Какие пары объектов находятся в отношении "объект - модель"?

А) компьютер – данные;
Б) компьютер - его функциональная схема;
В) компьютер – программа;
Г) компьютер – алгоритм.
2. Какая модель компьютера является формальной (полученной в результате формализации)?
А) техническое описание компьютера;
Б) фотография компьютера;
В) логическая схема компьютера;
Г) рисунок компьютера.
3. Информационной моделью, которая имеет табличную структуру является ...
А) файловая система компьютера;
Б) таблица Менделеева;
В) генеалогическое дерево семьи;
Г) функциональная схема компьютера.
4. Какая модель является динамической (описывающей изменение состояния объекта)?
А) формула химического соединения;
Б) формула закона Ома;
В) формула химической реакции;
Г) закон Всемирного тяготения.

Дан целочисленный массив из 30 элементов. Элементы могут принимать значения от 160 до 200 ¬– рост учащихся выпускного класса. В баскетбольную команду

берут тех, чей рост не менее 180 см.Опишите на русском языке или на одном из языков программирования алгоритм, который подсчитывает и выводит минимальный рост игрока баскетбольной команды. Гарантируется, что хотя бы один ученик играет в баскетбольной команде. Исходные данные объявлены так, как показано ниже. Использовать другие переменные запрещается.

Код Pascal

cоnst N = 30;
var A: array[1..N] of integer;
i, x, y: integer;
s: real;
begin
for i:=1 to N do readln(A);
...
end.

Помогите, пожалуйста, решить задачу:

Дан вектор из 25 элементов. Найти минимальное значение. Записать на языке Pascal и построить алгоритм.



Вы находитесь на странице вопроса "Pascal, Динамические структуры данных.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.