Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

В полученной случайным образом последовательности N целых чисел из промежутка [10;1000] найти числа, у которых ровно 4 делителя.

10-11 класс

Ксюша661 21 нояб. 2016 г., 16:47:33 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vovchik1752
21 нояб. 2016 г., 18:25:00 (7 лет назад)

const n=?; {Вместо "?" вставить значение}
Var a:array[1..n] of integer;
i:integer;

Function del(x:integer):integer; {Функция для определения кол-ва делителей}
var i,k:integer;
begin
 k:=0;
 for i:=1 to x do
   if (x mod i)=0 then k:=k+1;
 del:=k;
end;

Begin
 randomize;
 for i:=1 to n do
   a[i]:=random[10,1000];
 for i:=1 to n do
   if del(a[i])=4 then write(a[i],' ');
End.

+ 0 -
13122013h
21 нояб. 2016 г., 19:38:40 (7 лет назад)

Единицу и само число делителем считать?

+ 0 -
Warfare12
21 нояб. 2016 г., 20:14:56 (7 лет назад)

да

Ответить

Другие вопросы из категории

Нужно решить в С++

1. Вычислить произведение последних трех чисел не кратных 5 в диапазоне
от 20 до 50.

1) Даны массивы А и В размерности n.

Сформировать массив С по следующему правилу:
С[

каковы функции мыши компьютера

Читайте также

Дан массив целых чисел из n

элементов, заполненный случайным образом числами из промежутка [-10,60]. Удалить из него все элементы, в
которых последняя цифра нечетная, а само число кратно 3.
Помогите пожалуйста решить в C# (Си шарп)

Написать программу, которая считает и выводит на экран сумму всех целых чисел из промежутка [A, B]. Числа A и B задает пользователь.

Программу реализовать с помощью трех циклических алгоритмов:
1) Цикл со счетчиком for
2) Цикл с предусловием while
3) Цикл с постусловием repeat
В программе предусмотреть ситуацию, когда пользователь вводит значение B ‹ A
Пример 1:
Пользователь вводит числа A=5, B=10. Сумма чисел: 5+6+7+8+9+10. Вывод на экран: 45
Пример 2:
Пользователь вводит числа A=7, B=4. Сумма чисел: 4+5+6+7. Вывод на экран: 22
Пример 3:
Пользователь вводит числа A=5, B=5. Сумма чисел: 5. Вывод на экран: 5



Вы находитесь на странице вопроса "В полученной случайным образом последовательности N целых чисел из промежутка [10;1000] найти числа, у которых ровно 4 делителя.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.