Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

1)Дано целое многозначное число n.Найти сумму цифр этого числа 2)Найти произведение первых n натуральных чисел. 2)Найти произведение первых n

5-9 класс

натуральных чисел.

Лесная19 01 февр. 2017 г., 7:51:50 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Pechenko16
01 февр. 2017 г., 10:02:55 (7 лет назад)

а если число трехзначное?)))

 

var n,i,p:integer;

s:string;

Begin

  read(n);

  s:=str(n) ; {переводим число в строку}

  n:=0;

  for i := 1 to length(s) do

    n:= n+ int(s[i]); {переводим каждый символ строки обратно в цифру}

  writeln(n);

 

 read(n);

 p:=1;

 for i:= 1 to n do

   p:= P*i;

 writeln(p);

 

End.

Ответить

Другие вопросы из категории

У каждого человека есть имя. Есть оно и у файлов. Укажите имя, которое необходимо исправить:

А) "новый".txt;
B) А будет это так.MP3;
C) Морской мир. JPEG;
D) Сочинение.doc.

Помогите написать программу в Паскале пожалуйста))

Для заданного числа N составьте программу, вычисляющую сумму чисел по формуле: S=1/2+1/4+...+1/2*n

Решите все пожалуйста :)

Читайте также

Помогите пожалуйста решить задания:

1) Преобразуйте двоичное число в восьмеричное:1010100
2)Преобразуйте двоичное число в десятичное:100010
3)Преобразуйте двоичное число в шестнадцатеричное:1110001000
4)Преобразуйте восьмеричное число в двоичное:67
5)Преобразуйте восьмеричное число в десятичное:207
6)Преобразуйте восьмеричное число в шестнадцатеричное: 2246
7)Преобразуйте десятичное число в двоичное:404
8)Преобразуйте десятичное число в восьмеричное:283
9)Преобразуйте десятичное число в шестнадцатеричное:1001
10)Преобразуйте шестнадцатеричное число в двоичное:5D
11)Преобразуйте шестнадцатеричное число в восьмеричное:4C
12)Преобразуйте шестнадцатеричное число в десятичное: 35B

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.

Язык программирования С++.

1. Даны четыре действительных числа a, b, c, x. Выяснить, пройдёт ли кирпич со сторонами a, b, c, в круглое отверстие радиуса x?
2. Дано трёхзначное натуральное число. Найти сумму цифр этого числа.
3. В данном двузначном натуральном числе подсчитать, сколько цифр больших 6, но меньших 9.
4. Даны три действительных числа больших нуля. Выяснить, являются ли они сторонами прямоугольного треугольника?



Вы находитесь на странице вопроса "1)Дано целое многозначное число n.Найти сумму цифр этого числа 2)Найти произведение первых n натуральных чисел. 2)Найти произведение первых n", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.