Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите, мне очень срочно нужноооо решить это в программе паскаль а я дуб дубом. Пожалуйста, я вам баллов побольше выдам, только решитеее ТТ. Я начислю

5-9 класс

113 баллов. ну пожааалуйстаа

Имеются переменные x,y,z для положительных чисел вывести удвоенное произведение для отрицательных в квадрат.

VioletLangdon 26 июля 2014 г., 2:15:17 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alinamalgjg
26 июля 2014 г., 3:22:43 (9 лет назад)

program gt;
var a,b,c:real;
begin
read(a,b,c);
if(a>0)then a:=2*a else a:=a*a;
if(b>0)then b:=2*b else b:=b*b;
if(c>0)then c:=2*c else c:=c*c;
write(a,' ',b,' ',c);
end.

Ответить

Другие вопросы из категории

Помогите с 1м, пожалуйста)
Какие из перечисленных отношений являются отношениями части и целого?

1)процессор - материнская плата
2)маятник - часы
3)градус - температура
4) вагон - поезд
5) объектив - фотоаппарт
6) вода - стакан

Читайте также

Я прошу Вас,ребятка,помогите,мне очень срочно нужно.

Одномерный массив из 6 элементов с номерами от 3 до 8 заполнить случайным образом числами от 5 до 17. Поменять местами 5-ый и 7-ой элементы массива,а 4-ый элемент увеличить в 3 раза. Вывести на экран монитора первоначальный и преобразованный массивы в строчку.

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

ОЧЕНЬ СРОЧНО!!!!!!!

По каналу один за другим идут пароходы "Обь" и "Восток". Навстречу им идут один за другим пароходы "Мир" и "Енисей". Канал такой ширины, что два парохода в нем разойтись не могут. Но с одной стороны канал имеет расширение, в котором может поместиться один пароход. Как можно пароходам разойтись и продолжить свой путь?
Изобразите решение в виде схемы.ЗАРАНЕЕ СПАСИБО!(объясните,кто как может,очень срочно)

РЕБЯТА ПОМОГИТЕ ПЛИЗ ОЧЕНЬ СРОЧНО НАДО

1) Несуществующий тип шин:
1. адресная
2. данных
3. управления
4. аварийная
2) Надежность ЭВМ измеряется
1. ремонтопригодностью ЭВМ
2. количеством отказавших деталей
3. внутренней частотой микропроцессора
4. средним временем наработки на отказ
3)Чтобы преобразовать заголовок в подзаголовок с помощью панели "Структура" необходимо выполнить команду:
1. вверх
2. вниз
3.понизить уровень
4. повысить уровень
4) Арифметико-логическое устройство предназначено для
1. кратковременного хранения, записи и выдачи информации
2. связи между процессором и основной памятью
3. выполнения всех арифметических и логических операций над числовой и символьной информацией
4. формирования и подачи во все блоки ЭВМ в нужные моменты времени определенных сигналов управления
5) НЕ является служебной программа...
1. Архивация данных
2. Назначенные задания
3. Дефрагментация диска
4. Файловый менеджер
6) Формула это:
1. адреса ячеек и знаки арифметических операций
2. буквы и цифры, обозначающие адреса ячеек и знаки арифметических операций
3. набор стандартных констант
4. связь между исходными и рассчитываемыми данными
7) Расстояние между парами шрифтов называется:
1. кернинг
2. трекинг
3. кегль
4. интерлиньяж
8) Память, предназначенная только для чтения:
1. кэш
2. оперативная
3. постоянная
4. регистровая
9) результатом перевода десятичного числа 7(10) в двоичную систему счисления является число
1. 111(2)
2. 11(2)
3. 1000(2)
4. 110(2)
10) периферийные устройства выполняют функцию...
1. ввод и выдачу информации
2. управляет работой ЭВМ по заданной программе
3. хранение информации
4. обработку информацию



Вы находитесь на странице вопроса "Помогите, мне очень срочно нужноооо решить это в программе паскаль а я дуб дубом. Пожалуйста, я вам баллов побольше выдам, только решитеее ТТ. Я начислю", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.