Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Составьте программу,которая осущ ввод в массив с клавиатуры 10 целых чисел и вычисляет: четные числа умножает на 3,а нечетные - на 4

5-9 класс

Женечка791 16 июня 2015 г., 16:11:49 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ylkaa
16 июня 2015 г., 19:10:16 (8 лет назад)

Var   i:longint;   m:array[1..10] of longint;
Begin
for i:=1 to 10 do
begin
read(m[i]);
if m[i] mod 2 = 1 then
m[i]:=m[i]*4 else
m[i]:=m[i]*3;
end;
for i:=1 to 10 do
write(m[i],' ');
End.

+ 0 -
Alastria
16 июня 2015 г., 21:02:43 (8 лет назад)

вывести она что должна

Ответить

Другие вопросы из категории

Составьте

на Паскале программу, которая запрашивает возраст двух детей
(Саши и Маши), а затем выводит информацию о том, кто из них старше.

Сколько секунд минимум потребуется модему, передающему сообщения со скоростью 28800 бит/с, чтобы передать 100 страниц текста в 30 строк по 60 символов

каждая, при условии что каждый символ кодируется одним байтом?
А) 50 с
В) 6,25 с
С) 500 с
D) 62.5 c

Помогите, пожалуйста, срочно, информатика 9 класс!!! Написать программу, которая выводит на экран сообщение, в какую четверть координатной плоскости

попала точка с заданными координатами. Координаты точки вводятся с клавиатуры.
Например, X=4, Y=6 она должна вывести "точка лежит в 1 четверти"

Читайте также

Помогите составить программу по информатике в Pascal ABC. Задание 1. С клавиатуры одной строковой вводят имя и фамилию. Составьте программу, которая:

а) определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и выводит его; в) выводит сначала фамилию, а затем имя. Задание 2. Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на "Янка". Задание 3. Составьте программу, которая в строке "реки горы и болота": а) удаляет слово "горы"; б) Заменяет слово "болота" на "озера". Буду безмерно благодарна!!!

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.

1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди

элементов с нечётными индексами

2)составьте программу,которая заполняет массив a[1..10]случайными целыми числами в диапазоне от 0 до 10,находит максимальный элемент массива,а затем вычисляет,сколько раз он встречается в массиве



Вы находитесь на странице вопроса "Составьте программу,которая осущ ввод в массив с клавиатуры 10 целых чисел и вычисляет: четные числа умножает на 3,а нечетные - на 4", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.