Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Приведен текст программы на языке Pascal:

10-11 класс

Var n, s : Integer;
Begin
Readln (n);
s:=0;
While n>0 Do
Begin
s:=s+n mod 10;
n:=n div 10
End;
Writeln (s)
End.
Расположите перечисленные исходные данные для этой программы (значения переменной n) в порядке УБЫВАНИЯ результатов (значения переменной s) работы программы.
1) 95
2) 502
3) 10023
4) 8
5) 613

Gadirova 23 февр. 2014 г., 20:49:54 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lilila
23 февр. 2014 г., 23:06:18 (10 лет назад)

mod - остаток от деления
div - целочисленное деление

95 - 14
502 - 7
10023 - 6 
8 - 8
613 - 10
второе число - это результат выполнения программы
в порядке убывания S будет
14  
10
8
7
6
соответственно  95   613    8    502    10023

Ответить

Другие вопросы из категории

помогите как можете
Паскаль

Проверить, будет ли файл, состоящий из целых чисел симметричен.
(первый символ должен быть равный последнему, второй символ равен предпоследнему и т.д)

Читайте также

Напишите на языках Pascal и C++ программу, которая генерирует 2 случайных вещественных числа и вычисляет их сумму, разность, произведение и

частное. Напишите на языках Pascal и C++ программу, моделирующую выбор одной из костей домино ( в наборе 28 костей домино, каждая состоит из двух половин, на каждой половине – от 0 до 6 очков). С помощью этой программы ответьте на вопрос: какова вероятность того, что выпадет кость с числом очков, кратным 3

1) Напишите пожалуйста программу (на языке BASIC) вычисления по длинам двух сторон треугольника и углу между ними длины третьей стороны и двух других

углов.
2)
Напишите пожалуйста программу (на языке BASIC) для определения подобия:
а) двух прямоугольников по двум смежным сторонам;
б) двух треугольников по трем сторонам.

Написать программу на языке Паскаль для вычисления значений функции y (см. для своего варианта) на интервале [a,b] с шагом h. Значения a,b и h ввести с

клавиатуры. На экран вывести результат вычислений в виде таблицы. 1 Блок-схема алгоритма программы, выполненная с использованием графических средств редактора WORD; 2 Текст программы; 3 Результаты выполнения (копия экрана). (3x+2)^2- sqrt3x/(3x)^2 a 5;b 7; h 0,1

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!



Вы находитесь на странице вопроса "Приведен текст программы на языке Pascal:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.