Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Услуги телефонной связи оплачиваются по следующему правилу: за разговоры до 1000 минут в месяц оплачиваются 12 рублей в минуту, а разговоры сверх

5-9 класс

установленной нормы оплачиваются из расчета 15 рублей за минуту. Написать программу, вычисляющую плату за пользование телефоном для введенного времени разговоров за месяц. Нужна блок-схема.

Bagimmamedova 27 февр. 2014 г., 17:03:39 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Krasoo114
27 февр. 2014 г., 19:48:52 (10 лет назад)

var
a,b,c:longint;
begin
readln(a);
if a<=1000 then begin writeln(12*a); exit; end else 
                                               begin
                                                  b:=12000;
                                                  c:=b+((a-1000)*15);
                                                end;
writeln(c);
end.

Ответить

Другие вопросы из категории

Напишите для паскаля,пожалуйста.

С клавиатуры вводятся 17 чисел. Найти произведение положительных чисел не делящихся на 17.
(Мы прошли только до цикла с постусловием)

Продолжите фрызы

1) Файл
2) Пользователь
3)Пользовательский интерфейс

Разгадайте анаграммы

1. АТОАРСРВЯ
2. ПРАЕТРМА
3. ЕТРАВКОНЯ
4. РКАЬАФАТЛНЯ


Найдите зашифрованные в сканворде понятия информатики

Читайте также

Цепочки символов (строки) создаются из букв латинского алфавита по следующему правилу: Первая строка состоит из двух символов – это буквы

«AB».

Каждая из последующих цепочек создается такими действиями: в начало записывается буква, следующая по алфавиту, далее записывается предыдущая строка и она же в обратном порядке символов (справа налево).

Вот первые 4 строки, созданные по этому правилу:

(1) AB

(2) BABBA

(3) CBABBAABBAB

(4) DCBABBAABBABBABBAABBABC

Сколько раз буква А встречается в 8-ой строке?

Цепочка из четырех бусин, помеченных латинскими буквами, формируется по следующему правилу:

– на третьем месте цепочки стоит одна из бусин A, E;
– на втором месте – одна из бусин H, E, D, которой нет на третьем месте;
– в начале стоит одна из бусин H, A, C, которой нет на втором месте;
– в конце – одна из бусин H, E, D, не стоящая на первом месте.
Определите, сколько из перечисленных цепочек созданы по этому правилу?
HDEE HHAE HEAE AHAH AEAD AEED CAEH EHAD CDEAВ
с решением, пожалуйста

Помогите пожалуйста,ребят. Прошуу..

На паскале
Оплата за электроэнергию производится по следующему правилу: за потребленную мощность до А кВт в месяц оплачивается В рублей за 1 кВт, а за потребленную. энергию сверх установленной нормы оплачивается из расчета С рублей за 1 кВт. Напишите программу, которая вычисляет плату за потребленную электроэнергию.

Строки (цепочки латинских букв) создаются по следующему правилу. Первая строка состоит из одного символа - латинской буквы "А". Каждая из последующих

цепочек создается такими действиями: в очередную строку сначала записывается буква, чей порядковый номер в алфавите соответствует номеру строки (на i-м шаге пишется "i"-я буква алфавита), к ней слева и справа приписывается предыдущая строка. Вот первые 3 строки, созданные по этому правилу:
(1) A
(2) ABA
(3) ABACABA
Запишите шесть символов подряд, стоящие в седьмой строке со 122-го по 127-е место (считая слева направо).

Строки (цепочки символов латинских букв) создаются по следующему правилу.

Первая строка состоит из одного символа – латинской буквы «А». Каждая из последующих це-почек создаётся такими действиями: в очередную строку сначала записывается буква, чей поряд-ковый номер в алфавите соответствует номеру строки, к ней слева дважды подряд приписывает-ся предыдущая строка.
Вот первые 4 строки, созданные по этому правилу:
(1) A
(2) AAB
(3) AABAABC
(4) AABAABCAABAABCD
Выпишите буквы, которые могут стоять в 256 позиции в девятой и всех последующих стро-ках. Ответ обосновать. Латинский алфавит для справки: ABCDEFGHIJKLMNOPQRSTUVWXYZ



Вы находитесь на странице вопроса "Услуги телефонной связи оплачиваются по следующему правилу: за разговоры до 1000 минут в месяц оплачиваются 12 рублей в минуту, а разговоры сверх", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.