Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Срочно нужно решение задачи Pascal. Дан массив.Найти сумму кубов всех элементов массива.

5-9 класс

Kod0908 17 авг. 2014 г., 2:10:57 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ШОНЧАЛАЙ
17 авг. 2014 г., 3:04:25 (9 лет назад)

{Лови прогу для одномерного массива. Если он двумерный, могу модифицировать.
Должна работать, не работает - отпишись, отыщу паскаль и исправлю.
Кидай прям весь ответ, кэп. Комментарии подотри, опять же кэп}

program massiv;
var x:array[1..10] of real;
n, i:integer;
s:real;

begin
writeln('Vvedite razmer massiva');
readln(n);
if (n<1) or (n>10) then writeln('Neverno zadano znacheniye razmera massiva')
else begin {check: +}
for i:=1 to n do begin writeln('Vvedite element ', i, 'iz ', n); readln(x[i]); end; {enter the array}
s:=0;
for i:=1 to n do
begin
s:=s+power(x[i], 3);
end;
writeln(s:2:2);
end;
readln; {stop here to read the program answer}
end.

+ 0 -
Lionorka83
17 авг. 2014 г., 5:22:41 (9 лет назад)

всмысле одномерный?

+ 0 -
Pupupip
17 авг. 2014 г., 5:53:53 (9 лет назад)

Массивы бывают одномерными, двумерными, трёхмерными и так далее
Одномерные частенько называют векторами, двумерные - матрицей. Дальше не помню

+ 0 -
Nov1978
17 авг. 2014 г., 8:01:56 (9 лет назад)

Ну я даже незнаю какой, возможно двухмерный а может и больше. Нужно найти сумму кубов всех элементов массива, для этого используется функция Power только как решать я хз)

+ 0 -
JohnKro
17 авг. 2014 г., 8:45:24 (9 лет назад)

Power? Не слышал

+ 0 -
SlavikFox
17 авг. 2014 г., 11:23:07 (9 лет назад)

А, отыскал. Ща изменю

Ответить

Другие вопросы из категории

имеются два файла одинакового размера элементами которого являются

отдельные символы. Переписать с сохранением порядка следования элементы
первого файла во второй а элементы второго файла в первый. использовать
вспомогательный файл. (написать в паскале надо программу)


переведите число 1025

в двоичной системе

помогите ответить на вопросы пожалуйста буду очень благодарна:* 1)сколько цветов будет содержать палитра,если каждый базовый цвет кодировать

двумя битами?

2)что такое электронные словари?

3)какие дополнительные проблемы возникают при переводе текстов?

4)что отличает систему перевода текста от электронного словаря?

5)почему отсканированный текст нельзя сразу обрабатывать текстовым редактором?

6)что такое распознавание текста?

Читайте также

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.

РЕБЯТА ПОМОГИТЕ ПОЖАЛУЙСТА ПОМОГИТЕ ПОЖАЛУЙСТА!!НУЖНО РЕШЕНИЕ ЗАДАЧИ,ОТ РЕШЕНИЯ ЭТОЙ ЗАДАЧИ,ЗАВИСИТ МОЯ ОЦЕНКА. БУДУ ОЧЕНЬ БЛАГОДАРНА

Создать целочисленный массив из 15 чисел. Заполнить с помощью генератора случайных чисел с элементами от -15 до 30. И вывести его на экран. Определить самый большой элемент массива и его индекс.
A (i):=random (x) -15
от -1 до х
от -15 до 30.

Помогите пожалуйста решить задачи!!!

Задание 1. Составить программу для вычисления по формуле:

Y = √|2x² - 7x| + 12
Задание 2.
Составить программу для вычисления значения функции:
F(x) = \left \{ {{0, If x <=2} \atop {1/(x^{2}+ 6), if x>1 }} \right. {{

Задание 3. Дано натуральное N. Вычислить: S=2*4*6*...*2N.
Задание 4. Дан массив А(20), заполненный датчиком случайных числе. Найти среднее арифметическое всех элементов массива.
Задание 5. дана матрица А(10,10), заполненная датчиком случайных чисел. Найти сумму значений всех элементов данной матрицы.

Помогите составить программу решения задачи в паскаль АВС.

Даны два целых числа А и В (А меньше В). Найти сумму квадратов всех целых чисел от А до В включительно.



Вы находитесь на странице вопроса "Срочно нужно решение задачи Pascal. Дан массив.Найти сумму кубов всех элементов массива.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.