Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

PASCAL

10-11 класс

Пользователь вводит одномерный массив(1..15).Вывести его в обратном порядке и посчитать произведение элементов.

Посчитать произведение элементов,стоящих на главной диагонали массива 4:4,введенного пользователем.Сам массив выписать

Дан целочисленный массив из 20 элементов.Элементы массива могут принимать целые значения от 0 до 10000 включительно.Опишите их алгоритм,позволяющий найти и вывести макс. значение среди трехзначащих элементов массива,не делящихся на 9.Если в исходном массиве нет элементов,которые явл. трехзнач. числов,при этом не кратно 9,то выведет сообщение не найдено.

Никкросс 04 окт. 2014 г., 17:39:47 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Maky1
04 окт. 2014 г., 19:07:47 (9 лет назад)

var a:array[1..15] of integer;
i:integer;
begin
for i:=1 to 15 do
read(a[i]);
for i:=15 downto 1 do
write(a[i],' ');
end.

var a:array[1..4,1..4] of integer;
i,j,s:integer;
begin
for i:=1 to 4 do
  for j:=1 to 4 do begin
  read(a[i,j]);
  if i=j then s+=a[i,j];
  end;
for i:=1 to 4 do begin
  for j:=1 to 4 do
  write(a[i,j]:3);
writeln;
end;
writeln(s);
end.

var a:array[1..20] of integer;
i,max:integer;
begin
for i:=1 to 20 do begin
read(a[i]);
if (a[i]>=100) and (a[i]<1000) and (a[i] mod 9 <> 0) and (a[i]>max) then max:=a[i];
end;
if (max<>0) then writeln(max)
else writeln('Не найдено');
end.

Ответить

Другие вопросы из категории

Паскаль!

5. Дано трехзначное число. Кратна ли сумма его цифр семи?
8. Дано три натуральных числа x, y, z. Вычислить количество чисел меньших 50.

1)Что обозначает слово код-

2)Что обозначает слово кодирование-
3)Что обозначает слов декодирование-

Составьте программу для ввода и вывода температуры за неделю. Результат может быть таким: 1 сентября температура была 17 2

сентября температура была 15

3 сентября температура была 16

4 сентября температура была 19

Читайте также

Напишите на языках Pascal и C++ программу, которая генерирует 2 случайных вещественных числа и вычисляет их сумму, разность, произведение и

частное. Напишите на языках Pascal и C++ программу, моделирующую выбор одной из костей домино ( в наборе 28 костей домино, каждая состоит из двух половин, на каждой половине – от 0 до 6 очков). С помощью этой программы ответьте на вопрос: какова вероятность того, что выпадет кость с числом очков, кратным 3

В языке Pascal есть функция Pandom (a), которая служит для получения случайного ряда чисел из интервала (0;а). Вопрос: придумать, как можно при помощи

формул языка Pascal сделать так, чтобы случайные числа выпадали в интервале (a;b)

Скажите по конкретнее, что нужно знать чтобы научиться программировать в Pascal - что именно нужно изучить...

У нас на первом курсе тема Pascal, а я гляжу на него как баран на новые ворота...
Я отстал сильно на 2 недели и ни могу ни как понять его... Скажите пожалуйста по конкретнее с чего начать, что именно нужно изучить или выучить, понять, чтобы знать как составлять на нём программы ?

ЗАДАЧА ДЛЯ PASCAL ABC: В группе 30 учеников. За выполненный тест они могут

получить от 5 до 15 баллов (Сгенерить случайные числа

Помогите, пожалуйста, решить задачу:

Дан вектор из 25 элементов. Найти минимальное значение. Записать на языке Pascal и построить алгоритм.



Вы находитесь на странице вопроса "PASCAL", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.