Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Помогите решить задачу пожалуйста.

10-11 класс

Вывести на экран все числа из интервала (А, В), числа стоящие за ними, произведение этих чисел.

Mashavotintsev 09 янв. 2015 г., 5:41:59 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ladybird18
09 янв. 2015 г., 6:31:44 (9 лет назад)

var a,b,i,p:longint;
begin
read(a,b);
p:=1;
for i:=a to b do
begin
write(i,' ');
p:=p*i;
end;
writeln;
writeln(p);
end.

Ответить

Другие вопросы из категории

PASCAL

Пользователь вводит одномерный массив(1..15).Вывести его в обратном порядке и посчитать произведение элементов.

Посчитать произведение элементов,стоящих на главной диагонали массива 4:4,введенного пользователем.Сам массив выписать

Дан целочисленный массив из 20 элементов.Элементы массива могут принимать целые значения от 0 до 10000 включительно.Опишите их алгоритм,позволяющий найти и вывести макс. значение среди трехзначащих элементов массива,не делящихся на 9.Если в исходном массиве нет элементов,которые явл. трехзнач. числов,при этом не кратно 9,то выведет сообщение не найдено.

Паскаль!

5. Дано трехзначное число. Кратна ли сумма его цифр семи?
8. Дано три натуральных числа x, y, z. Вычислить количество чисел меньших 50.

1)Что обозначает слово код-

2)Что обозначает слово кодирование-
3)Что обозначает слов декодирование-

Составьте программу для ввода и вывода температуры за неделю. Результат может быть таким: 1 сентября температура была 17 2

сентября температура была 15

3 сентября температура была 16

4 сентября температура была 19

Читайте также

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

ПОМОГИТЕ РЕШИТЬ ЗАДАЧУ ПОЖАЛУЙСТА.я пропустила тему. Дан одномерный массив А состоящий из 10

элементов.Вывести на экран исходную таблицу и резултат программы.

Найти произведения элементов массива А. удовлетворяющих условию:

c<=A[i]<=d.

Ребята, помогите решить задачу, пожалуйста!

Oпределите значение d после выполнения фрагмента программы:
d:=3255;
f:=d div 15-17;
z:=d div (f*5);
d:=d mod (z+1);

ПОМОГИТЕ РЕШИТЬ ЗАДАЧУ ПОЖАЛУЙСТА.я пропустила тему.ПО ПАСКАЛЬ.!!

Дан одномерный массив А состоящий из 10 элементов.Вывести на экран исходную таблицу и резултат программы.
Найти произведения элементов массива А. удовлетворяющих условию:
c<=A[i]<=d.

помогите решить задачу пожалуйста


Вы находитесь на странице вопроса "Помогите решить задачу пожалуйста.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.