Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Написать программу, в которую вводят 10 чисел с клавиатуры и находят их произведение + составить блок-схему. Помогите, пожалуйста.

10-11 класс

Tana7777 08 июня 2015 г., 21:32:19 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Анянюрка11
08 июня 2015 г., 22:04:51 (8 лет назад)

Вот программа, блок-схему сами.

P.S Вылетает при вводе больших чисел

 

Program P1;
Var n, i : Integer;
s : LongInt;

Begin
s := 1;
For i := 1 to 10 do
Begin
Write('Введи ', i, ' число: ');
Readln(n);
s := s * n;
End;

Write('Произведение = ', s);
Readln;
End.

Ответить

Другие вопросы из категории

Написать программу вычисления стоимости некоторого количества (по весу) яблок.

Ниже приведен рекомендуемый вид экрана во время выполнения программы (данные,
введенные пользователем, выделены полужирным шрифтом).
Вычисление стоимости покупки.
Введите исходные данные:
Цена
одного килограмма яблок (руб.) -> 8.5
Вес яблок (кг) ->
2.3
Стоимость покупки: 19.55 руб.

Сидорова Маша сохраняла себе на компьютер файл. Скорость закачки файла у неё в сети была 180 Кбит/секунду. После того, как она скачала половину файла,

скорость увеличилась в пять раз. Какое время ей понадобилось, чтобы скачать весь файл размером 910 Мбайт. Ответ записать в часах, округлив по математическим правилам до целых чисел (без единиц измерения).

Записать на языке программирования ( паскаль):

1)5* корень( 2х- у^2) - у^3/5
2)корень (у^4)

Читайте также

1. Составьте блок-схему и программу вычисления значения функции:

2. Составьте программу, определяющую, является ли данное число делителем числа 3.
3*. Составьте программу, заменяющую из двух данных чисел меньшее число суммой, а большее – произведением этих чисел.

составить графическую схему алгоритма и написать программу с организацией ввода-вывода с помощью текстовых файлов. В каждой задаче задается квадратная

матрица NxN. Программа должна осуществлять ввод и печать исходной матрицы и возможно, дополнительных данных, произвести необходимые действия и напечатать результаты. Подсчитать общее количество чисел, меньших заданного А, и чисел, больших заданного В среди элементов, находящихся ниже побочной диагонали.

1)Написать программу вывода всех четных чисел от 2 до 1000 включительно

2)Написать программу определяющую сумму всех нечетных чисел от 1 до 99

написать программу с организацией ввода-вывода с помощью текстовых файлов. В каждой задаче задается квадратная матрица

NxN. Программа должна осуществлять ввод и печать исходной матрицы и возможно, дополнительных данных, произвести необходимые действия и напечатать результаты.

Найти в каждом четном по номеру столбце матрицы максимальный элемент и вычислить произведение этих элементов.



Вы находитесь на странице вопроса "Написать программу, в которую вводят 10 чисел с клавиатуры и находят их произведение + составить блок-схему. Помогите, пожалуйста.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.