Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Даны два целых числа а и b. Если а делится на b или b делится на a, то вывести 1,

10-11 класс

иначе – любое другое число.

Atatyana 30 авг. 2016 г., 18:50:49 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sashavoronin
30 авг. 2016 г., 20:04:05 (7 лет назад)

...
if (a mod b = 0) or (b mod a = 0) then written('1') else written('0');
...
––––––––––––––––
Не понятно - пиши

+ 0 -
Rostf
30 авг. 2016 г., 20:42:16 (7 лет назад)

var
a,b:Integer;
Begin
 Read(a,b);
 if (a mod b=0) or (b mod a=0) then Writeln('1')
  else Writeln('0');
end.

Ответить

Другие вопросы из категории

Сформировать квадратную матрицу порядка n по заданному образцу:

n 0 0 ... 0 0 0
0 n-1 0 ... 0 0 0
0 0 n-2 ... 0 0 0
. . . ... . . .
0 0 0 ... 0 2 0
0 0 0 ... 0 0 1

C++ программирование помогите
Помогите с 11 и 12 заданиями

Читайте также

Даны два целых числа A и B (A < B). Вывести в

порядке возрастания все целые числа, расположенные между A и B(в том числе A и B),
a также количество N этих чисел
ЦИКЛ с ПАРАМЕТРОВ

1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.

Даны два целых

числа A и B (A < B). Вывести все целые числа,
расположенные между данными числами (включая сами эти числа), в порядке их
возрастания (убывания), а также количество N этих чисел (с использованием
оператора for, while, repeat)

Даны два целых числа А и В (А<В). Найти сумму всех целых чисел от А до В включительно Входные данные: ввести два целых числа А,В (1<=A,

B<=100).

Выходнфе данные: вывести сумму всех целых чисел от А до В включительно.

Можно, пожалуйста, с объяснением.

. Даны два целых числа A и B

(A < B). Найти произведение всех целых чисел от A до B
включительно.



Вы находитесь на странице вопроса "Даны два целых числа а и b. Если а делится на b или b делится на a, то вывести 1,", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.