Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

помогите пожалуйста,(паскаль)

10-11 класс

Мавыйка001 21 апр. 2013 г., 9:07:47 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ZulyaS
21 апр. 2013 г., 10:57:27 (11 лет назад)

Могут быть небольшие ошибки
var a,c,i:integer;
begin
read ln (a);
for i:=1 to a do
begin
if a mod i = 0 then
c:=c+1;
end;
if c<2 then
write ('простое');
end.

+ 0 -
Kiska330691
21 апр. 2013 г., 12:48:56 (11 лет назад)

Uses Crt; 
var i,f,n:integer;begin    write('Введите число:');     readln(n);     for i:=2 to trunc(sqrt(n)) doif (n mod i)=0 then f:=1;if (f=0) then write('Число Простое')
           else writeln('Число не является простым');   readkey;end. В любом случае правильное решение:)

Ответить

Другие вопросы из категории

ABS PASCAL -это .......
Решение в ПАСКАЛЕ!!! фермер построил две теплицы одинаковой длины L (M). Первая теплица имеет в поперечном сечении форму прямоугольника со

сторонами размером А на В (метров), вторая - полукруг радиуса R (М). Определить, сколько метров полиэтиленовой плётки необходимо фермеру для укрытия всей поверхности теплиц (включая торцы).

Читайте также

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите пожалуйста.паскаль АВС

Треугольник задан координатами своих вершин.Составить программу вычисления площади треугольника.



Вы находитесь на странице вопроса "помогите пожалуйста,(паскаль)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.