Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Написать программу

5-9 класс

Трехзначное число в 5 раз больше произведения своих цифр. Какое это число?

Msain 11 сент. 2013 г., 9:01:55 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Andre129
11 сент. 2013 г., 11:40:09 (10 лет назад)

var k, l, m, s,n: real;
var st:string;
begin
  for var i:=100 to 999 do
   begin  
    k:=(i div 10)div 10;
    l:=((i div 10)mod 10);
    m:=i mod 10;
    s:=k*l*m;
    n:=i/5;
    if s=n then st:='  -----------' else st:='';
    writeln(k,'*',l,'*',m,'=',s,'  ',i,'/5=',n,st);
  end;
end.


Нужное число будет помечено несколькими тире, остальные числа выводятся для доказательства того, что всё работает правильно.

Ответить

Другие вопросы из категории

бейсик.) На узкой улице заклинило тормоза у «Волги». Шофер грузовика предложил помочь убрать «Волгу» с проезжей части дороги, оттащив ее на обочину с

помощью троса. Составить алгоритм ответа на вопрос: «Удастся ли оттащить «Волгу»?

Читайте также

1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего – в куб и нахождения среднего

арифметического полученных значений.
2. За весну Обломов похудел на p1 кг, за лето поправился на p2 кг, за осень похудел на p3 кг, за зиму поправился на p4 кг. Написать программу, определяющую, похудел или поправился за год Обломов.
3. Написать программу, которая определяет, является ли целое число четным двузначным числом.
4. Даны коэффициенты квадратного уравнения. Написать программу, определяющую его корни

помогите пожалуйста..очень надо....что нибудь из этих задач..1)написать программу которая поменяет местами первую и последнюю букву в слове. 2)написать

программу которая вставит между буквами веденного слова пробелы 3)написать программу вывода на экран деление двух чисел

5-9 класс информатика ответов нет
Паскаль ABC 1.Написать программу рисующую вертикальную цепочку из 7 кругов 2.Написать программу рисующую цепочку из 5 кругов

расположденных по диагонали

3.Написать программу рисующую горизонтальную цепочку из 12 кругов,каждый круг должен на половину закрывать предыдущий

Помогите,а то сижу с паскалем уже час с лишним и все никак не получается..

Заранее спасибо)

Написать программу для определения максимального числа из данных пяти чисел.

Пользователь вводит пять чисел. Программа выводит ответ: "Максимальное число ... ".
Написать программу в "КуМиРе"

Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу, определяющую, как

соотносятся между собой два произвольных числа A и B.

2. Фирма осуществляет набор сотрудников. Условия приема требуют не менее 3 лет рабочего стажа и возраст не более 35 лет. Написать программу, проверяющую, удовлетворяет ли кандидат этим требованиям.



Вы находитесь на странице вопроса "Написать программу", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.