Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Прошу вас, помогите! Решается оценка!!! Найдите ошибки в программе 1)Program z1; var a:integer; begin a:=10; while

5-9 класс

a<5 do

writeln(a);

a:=a+1;

End.

2)Program z2;

var a,s:integer;

begin

a:=1; s:=0;

while a<10 do begin

s:=s+a/2;

end;

writeln(s);

end.

Nastya28112003 14 авг. 2014 г., 10:22:30 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lizka1274
14 авг. 2014 г., 11:45:46 (9 лет назад)

в 1 программе  значение переменной а больше чем в цикле и  поэтому 10 не меньше 5 и цикл не выполняется

2 ошибка в том, что writeln выводит значение, а после  него еще есть условие про а

Если бы а было меньше пяти,то программа зациклилась из за a:=a+1 ,но если бы было меньше пяти и эта строчка была выше writeln (a),то цикл выполнился

 

Во 2 программе 

s:=s+a/2 получится  не целое число,которое соответсвует типу real  

Ответить

Другие вопросы из категории

дополни предложения ! помогите плиз управлять компьютером можно, выбирая нужную команду из заранее заготовленных вариантов-..........

щелчком по кнопке ......открывается окно.
все программы -важный пункт.........

128^ x-3 Кбайт=64^x бит.
Мне нужна программа Power Point. Уже скачала кучу и все с "бесплатными СМС" стоимостью в 70 рублей! Кто сможет найдите мне такую программу БЕЗ регистраций

и БЕЗ СМС. Или найдите плиз программу, чтобы можно было нормальные презентации делать((

Читайте также

пожалуйста помогите очень надо!!! В массиве храниться информация о стоимости товаров. Составьте программу, которая определяет стоимость самого

дешевого(дорогого) товара и его индекс.

вот программа но в ней где-то ошибка

program xxx;

var a:array [1..10] of integer;

i, max, min:integer;

begin

for i:=1 to 10 do read(a[i]);

min:=1;

for i:=2 to 10 do

if a[i]<min then min:=a[i];

writeln('a[',i,']=',a[i]);

max:=a[i];

for i:=2 to 10 do

if a[i]>max then max:=a[i];

writeln('a[',i,']=',a[i]);

end.

program mar; uses crt; var F,k:integer; S:real; begin clrscr; F:=1; S:=1; for k:=1 to 3 do

begin

F:=F*k;

S:=S*(2*F)/(k*k*k*k+k);

writeln('k = ',k );

readkey;

end.

Найдите ошибку, пожалуйста, программа не идет.



Вы находитесь на странице вопроса "Прошу вас, помогите! Решается оценка!!! Найдите ошибки в программе 1)Program z1; var a:integer; begin a:=10; while", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.