Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Составить программу, позволяющую решить задачу.

10-11 класс

Сильва123 26 авг. 2014 г., 0:57:32 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Superalievazi
26 авг. 2014 г., 1:36:35 (9 лет назад)

var
  now, b : real;
  years : integer;
begin
  write('Начальный вклад: ');
  readln(now);
  write('Конечный вклад (b): ');
  readln(b);
  years := 0;
  while now <= b do
  begin
    now := now + now * 3 / 100;
    years := years + 1;
  end;
  writeln('Потребуется лет: ', years);
end.

Ответить

Другие вопросы из категории

Дается последовательность из N чисел. Выведите разницу между максимальным и минимальным элементами последовательности.

Формат входных данных
Первая строка входного файла содержит целое число N (1 <= N <= 100000). В следующей строке задаются N положительных целых чисел, каждое из которых не превышает 100000.

Треугольник задан длинами своих сторон – a, b, c. Определить является ли

он тупоугольным, прямоугольным или остроугольным

Сделать разветвляющуюся алгоритмическую структуру.

Написать программу, которая считает и выводит на экран сумму всех целых чисел из промежутка [A, B]. Числа A и B задает пользователь.

Программу реализовать с помощью трех циклических алгоритмов:
1) Цикл со счетчиком for
2) Цикл с предусловием while
3) Цикл с постусловием repeat
В программе предусмотреть ситуацию, когда пользователь вводит значение B ‹ A
Пример 1:
Пользователь вводит числа A=5, B=10. Сумма чисел: 5+6+7+8+9+10. Вывод на экран: 45
Пример 2:
Пользователь вводит числа A=7, B=4. Сумма чисел: 4+5+6+7. Вывод на экран: 22
Пример 3:
Пользователь вводит числа A=5, B=5. Сумма чисел: 5. Вывод на экран: 5

1)Сколько бит информации несет сообщение о том,что занятия состоятся в одной из 36 аудиторий?

2) Какое число следует за каждым из данных: (а) 667(внизу 8) (б) 101(внизу 2)
3) Выполните арифметические операции: (а)11010110(внизу 2) + 1111001(внизу 2)
(б) 1110(внизу 2) * 1001(внизу 2) (в) 1100011(внизу 2) - 11111(внизу 2)

Читайте также

Помогите, пожалуйста, решить задачи.

1. В один из жарких летних дней Петя и его друг Вася решили купить арбуз. Они выбрали самый большой и самый спелый, на их взгляд. После недолгой процедуры взвешивания весы показали w килограмм. Поспешно прибежав домой, изнемогая от жажды, ребята начали делить приобретенную ягоду, однако перед ними встала нелегкая задача. Петя и Вася являются большими поклонниками четных чисел, поэтому хотят поделить арбуз так, чтобы доля каждого весила именно четное число килограмм, при этом не обязательно, чтобы доли были равными по величине. Ребята очень сильно устали и хотят скорее приступить к трапезе, поэтому Вы должны подсказать им, удастся ли поделить арбуз, учитывая их пожелание. Разумеется, каждому должен достаться кусок положительного веса.
Входные данные
В первой и единственной строке входных данных записано целое число w (1 ≤ w ≤ 100) — вес купленного ребятами арбуза.
Выходные данные
Выведите YES, если ребята смогут поделить арбуз на две части, каждая из которых весит четное число килограмм, и NO в противном случае.
Примечание
Например, ребята могут поделить арбуз на две части размерами 2 и 6 килограммов соответственно (другой вариант — две части 4 и 4 килограмма).

2. На клетчатой плоскости заданы координаты K зданий. Требуется построить кольцевую дорогу вокруг зданий минимальной длины в виде прямоугольника, со сторонами, параллельными линиям сетки.
Входные данные
Во входном файле, на первой строке, находится число K( ). На следующих K строках находятся пары чисел и – координаты зданий
( ).
Выходные данные
Выведите в выходной файл координаты левого нижнего и правого верхнего углов прямоугольника.

3. Хакер Иван является сотрудником крупной антивирусной компании. Один из вирусов исследованием, которого он занимается, был специально создан для атаки на программы биржевой торговли.
Для того что бы победить зловред Ване необходимо разработать алгоритм, который бы вычислил минимальное количество операций необходимых для того что бы пара чисел (a, b) стала "k -красивой". Пара чисел (a, b) называется "k-красивой" если хотя бы одно из чисел парны не меньше заданного целого числа k. При этом, операции, проводимые с парой чисел (a, b) могут быть только такие:
1. Пара (a, b) может быть преобразована в (a+b, b);
2. Пара (a, b) может быть преобразована в (a, b+a).
Помогите Ване победить.
Входные данные
Единственная строка входных данных содержит три целых числа a, b и k ( - 1018 ≤ x, y, m ≤ 1018).
Выходные данные
Выведите минимальное количество операций или число -1, если сделать заданную пару "k-красивой" невозможно.

4. Инженер-программист Надежда занимается разработкой компилятора для нового сверх секретного языка программирования. Для того чтобы закончить разработку одного из модулей ей остается решить задачу следующего содержания:
Во входных данных Надя получает строку содержащую в себе цифры и скобки одного вида: '(' и ')'. Наде необходимо написать программу, которая для любых входных данных определяет является ли содержащаяся в них скобочная последовательность правильной, и в случае правильности скобочной последовательности возвращает количество встречающихся в ней скобок, если же последовательность неправильная, то выводится число -1.
Скобочная последовательность называется правильной, если:
1. Пустая строка — правильная скобочная последовательность;
2. Правильная скобочная последовательность, взятая в скобки одного типа — правильная скобочная последовательность;
3. Правильная скобочная последовательность, к которой приписана слева или справа правильная скобочная последовательность — тоже правильная скобочная последовательность.
Помогите Наде в разработке компилятора для нового сверх секретного языка программирования.
Входные данные
Единственная строка конечной длины содержит цифры и скобки, длина строки не больше 1024 символов.
Выходные данные
Выведите количество скобок если скобочная последовательность правильная или число -1 если нет.

5. Маленький Вася научился считать сумму цифр для любого числа. Для любого числа, он считал сумму его цифр, затем тоже самое он делал с полученным в результате числом и так далее. Определите сколько раз Васе необходимо посчитать сумму, чтобы она стала цифрой.
Входные данные
Одна непустая строка с числом (0 Выходные данные
Одна строка, с числом.

Составьте блок схему и напишите программу для данной задачи: дедка, бабка, жучка и кошка взяли в аренду колхозное поле. Засеяли поле репой.Пришла пора

убирать урожай.Составить программу отвечающую на вопрос:успеют ли арендаторы убрать урожай до холодов , не привлекая сезоного рабочего мышку

Решить задачи:

Задача 1. Составьте программу, которая заполняет массив а[1..10] случайными целыми числами в диапазоне от 1 до 10, затем меняет местами первый и последний элементы.

1. Составить программу для нахождения наибольшего числа из трех чисел.

2. Составить программу для упорядоченное двух элементов по убыванию.

1)составить программу, организующую массив записей о книгах, ввести информацию по следующим полям:автор, название, год издания. Провести сортировку и

вывести список книг, изданных после 2003 года.



2)составить программу , организующую массив записей о пяти студентах и их оценках по трем предметам. провести сортировку и вывести список отличников.



Вы находитесь на странице вопроса "Составить программу, позволяющую решить задачу.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.