Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

№1. Составить программу нахождения длины окружности и площади круга по указанному радиусу R. №2. Дано трехзначное число. Найти произведение цифр

5-9 класс

числа.

№3. Меньшее из трех чисел увеличить в 3 раза.

Marianaus 18 февр. 2015 г., 18:42:24 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ukrop27
18 февр. 2015 г., 20:24:28 (9 лет назад)

var r,l,s:real;
begin
write('R=');read(r);
s:=pi*sqr(r);
l:=2*pi*r;
write('S=',s,';L=',l);
end.

 

var a,p:integer;
begin
read(a);
p:=(a mod 10)*(a div 100)*(a mod 100 div 10);
write(p);
end.

 

var a,b,c,min:integer;
begin
writeln('Введи 3 числа');
readln(a,b,c);
min:=a;
if b<min then min:=b;
if c<min then min:=c;
writeln(3*min:4);
readln;
end.

+ 0 -
Oxasholpan
18 февр. 2015 г., 22:24:59 (9 лет назад)

Язык программирования: Паскаль 

№1.

R - радиус окружности
C - длина окружности
S - площадь круга
Взято число Пи, равное 3,14.

var
R, C, S : real;
begin
readln (R);
C := 2 * 3.14 * R; 
S := 3.14 * SQR(R);
writeln (C);
writeln (S); 
end.

№2

a - натуральное число
p - произведение цифр числа

var
a, p : integer;
begin
readln (a);
p := (a mod 10) * (a div 10 mod 10) * (a div 100);
writeln (p);
end.

№3.

a - первое число
b - второе число
c - третье число
Учитывая, что все числа разные.

var
a, b, c : integer;
begin
readln (a);
readln (b); 
readln (c); 
if (a < b) and (a < c) then
a := a * 3;
else
if b < c then
b := b * 3;
else
c := c * 3;
writeln (a);
writeln (b);
writeln (c); 
end.

Ответить

Другие вопросы из категории

Заполните таблицу, используя указанные выше ссылки на источники информации:Тип переменной :1Integer....2real......3char...Русское название типа:

1Целое,,,,2......3.....Диапазон значений: 1,,,,,2,,,,3,,,,
Допустимые значения:1,,,,2,,,3,,,,

Читайте также

1)Составить программу нахождения суммы квадратов чисел от 25 до 125.

2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=0)
3) найти сумму всех целых нечетных чисел меньших 100
4) найти сумму чисел в диапазоне от A до B кратных четырём. Числа А и В вводятся с клавы.
5) Найти все натуральный делители натурального числа n

1)Напишите программу,которая запрашивает значения двух переменных и выводит их разность.Приглашение к вводу каждого числа произведите в отдельных

строках.Вывод результата сопроводите пояснениями
2)Напишите программу ввода трех величин( А,В,С) на одной строке,рассчитайте и выдайте на экран на отдельной строке значение выражения: (А*В)/3,14 +3С.
3)Напишите программу вычисления длины окружности и площади круга одного и того же заданного радиуса R.
Решать на паскале...Помогите пожалуйста(((

составьте программу для определения,что больше площадь круга радиусом a или площадь квадрата со стороной a-значения числа a вводятся с

клавиатуры(площадь круга вычисляется по формуле:S=PR^2)помогите пожалуйста:(

паскаль

Проверочная работа по теме "Программирование в среде Паскаль"

1. Найти длину окружности и площадь круга, если известен радиус.
r - радиус (вводится пользователем)
p - длина окружности (находится по формуле p=2· \pi ·r)
s - площадь круга (находится по формуле s= \pi · r^{2} )
 \pi - число пи (3,14)
Тип переменных определить самостоятельно.

Составить программы через Паскаль ABC

1. Дана длина ребра куба а. Найти объем куба V = a3 ( третья степень ) и площадь его поверхности S = 6 *a2. а = 2.00 V = 8.000 S = 24.000
2. Даны длины ребер a, b, c прямоугольного параллелепипеда. Найти его объем V = а*b*c
и площадь поверхности S = 2*( а*b + b*c + a*c ) a = 8.40 b = 3.80 c = 9.40 V = 300.048
S = 293.200
3. Найти длину окружности L и площадь круга S заданного радиуса R : L = 2*П (пи)*R, S = П (пи)*R2 (в квадрате) П = 3.14 R = 1.50 L = 9.420 S = 7.065

P.S *- умножение



Вы находитесь на странице вопроса "№1. Составить программу нахождения длины окружности и площади круга по указанному радиусу R. №2. Дано трехзначное число. Найти произведение цифр", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.