Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

даны целые положительные числа M и N и набор из М чисел. Сформировать матрицу размера М х N , у которой в каждом столбце содержатся все числа из исходного

10-11 класс

набора (в том же порядке ) . из Pascal ABC.

Salov34rus 21 сент. 2016 г., 12:26:02 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Гулима
21 сент. 2016 г., 13:05:37 (7 лет назад)

const
  m = 8;
  n = 7;

var
  a: array[1..m, 1..n] of integer;
  i, j: integer;

begin
  writeln('Введите через пробел ', m, ' чисел');
  for i := 1 to m do
  begin
    Read(a[i, 1]);
    for j := 2 to n do a[i, j] := a[i, 1]
  end;
  Writeln('Сформированный массив');
  for i := 1 to m do
  begin
    for j := 1 to n do Write(a[i, j]:5);
    Writeln
  end
end.

Тестовое решение:

Введите через пробел 8 чисел
4 -6 10 93 345 -32 0 11
Сформированный массив
    4    4    4    4    4    4    4
   -6   -6   -6   -6   -6   -6   -6
   10   10   10   10   10   10   10
   93   93   93   93   93   93   93
  345  345  345  345  345  345  345
  -32  -32  -32  -32  -32  -32  -32
    0    0    0    0    0    0    0
   11   11   11   11   11   11   11



Ответить

Другие вопросы из категории

Нужна помощь по информатике. Нужно решить карточку. Желательно подробно!! ! Вот карточка: Хотя бы

несколько. Кому не сложно помогите!! ! Тема называется Представление
числовой информации с помощью систем счисления!

Преобразовать формулу
Описать

функцию Fact (n) вещественного типа вычисляющую значение факториала n!=1*2*3*..*n (n>0, параметр целого типа). С помощью этой функции найти
факториалы пяти данных целых чисел.

Каждый символ в

UNICODE закодирован
двух байтовым словом. Оцените информационный
объем следующего предложения в этой
кодировке:

С++

Как посчитать ln(x)
На сколько я знаю в с++ нет такой функции.

Читайте также

Дано целое положительное число. Проверить истинность высказывания: «данное число является нечетным трехзначным».

Входные данные: ввести одно целое положительное число a ((1<=a<=1000).
Выходные данные: вывести слово «true» если приведенное высказывание для предложенных исходных данных является истинным или «false» в противном случае.

Помогите с задачками в паскале. Даны три положительных числа а, в, с. Проверить будут ли они сторонами треугольника. Если да то

вычислить площадь этого треугольника. Даны два действительных положительных числа х и у. Арифметические действия над числами пронумерованы (1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление). Составить программу, которая по выведенному номеру выполняет то или иное действие над числами.

1) Задано положительное число A. Найти сумм всех четных чисел в интервале от 1 до A. Число А может иметь дробную часть.

2) Задано целое положительное число А и В. Найти квадратные корни целых чисел в интервале от А до В. Замечание: A<B

Очень прошу помогите с Паскалем!)

1. Напишите программу, вычисляющую площадь прямоугольника. С клавиатуры вводятся два действительных числа – стороны прямоугольника. Необходимо вычислить его площадь и вывести на экран. Вывод должен быть отформатирован следующим образом: под число отводится 10 знаков, а под вещественную часть – 3.
2. С клавиатуры вводятся 3 целых числа. Определить количество положительных чисел в этом наборе.
3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр.
4. С клавиатуры вводится натуральное число n. Узнайте в нем количество цифр.
5. С клавиатуры вводится натуральное число n. Посчитайте сумму S=1+2+…+n.
6. Даны целые положительные числа N и K. Используя только операции сложения и вычитания, найти частное от деления нацело N на K, а также остаток от этого деления.
7. С клавиатуры вводится натуральное число N. За ним последовательно вводятся данные о росте N учащихся класса. Определите средний рост учащихся всего класса. Попробуйте решить эту задачу без использования массивов.
8. Заполнить элементы массива последовательностью чисел: 2, 5, 10, 17, 26, …
9. Вводится число N, а за ним N целых чисел – элементов массива. Найдите количество отрицательных элементов в этом массиве.
10. С клавиатуры вводится число N. Выведите следующую фигуру (N-строк, на последней строке N звездочек). Подсказка: для решения этой задачи примените конструкцию «цикл в цикле».
*
* *
* * *
* * * *

* * * * * * *
11. Массив заполняется целыми числами до «нуля». Замените все положительные числа массив на противоположные им, а отрицательные возведите в квадрат. Выведите изменившийся массив.
12. На вход программе поступает целое число N. Выведите количество делителей N, включая 1 и само число N. Внимание: для решения этой задачи заведите счетчик и не забудьте сначала занести в него значение 0.



Вы находитесь на странице вопроса "даны целые положительные числа M и N и набор из М чисел. Сформировать матрицу размера М х N , у которой в каждом столбце содержатся все числа из исходного", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.