Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Решить задачи с помощью линейных алгоритмов !

5-9 класс

Заранее спасибо )

333ИринкА333 12 мая 2013 г., 14:57:30 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sasha603
12 мая 2013 г., 17:30:18 (10 лет назад)

№3

program fofgogjoj;
var
a,b,c,S,P:real;
begin
Writeln('Введите длину катета a');
Readln(a);
Writeln('Введите длину катета b');
Readln(b);
c:=sqrt(a*a+b*b);
P:=a+b+c;
S:=(1/2)*a*b;
Writeln('P=', P:0:2);
Writeln('S=', S:0:2);
end.

Ответить

Другие вопросы из категории

Введите массив из 10 чисел и выведите на экран только отрицательные значения этого массива(c номерами этих массивов,т.е. при выводе на экран

отрицательных значений будет написано,например:m[1]=-3).

Напишите,пожалуйста,программу.

что такое математическая модель

Читайте также

Решите задачу

Решите задачу с помощью рассуждения (рассуждения присылать тоже)
Задача: В одном доме живут 3 товарища: Вася, Боря и Дима.
Один из них играет в футбол, другой пишет стихи, а третий лучше всех играет в шахматы.
Известно : 1-ВАсин друг с огорчением сказал "Вчера я не сумел реализировать пинальти" 2-товарищ поэта сказал" Дима! Написал бы и ты что нибудь и для нашей футбольной команды"
Назовите имена футболиста, шахматиста, поэта (с рассуждением)

Решить задачи с помощью Паскаля:

1. Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать его по последней цифре.
2. Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать первую половину по возрастанию, а вторую- по убыванию. Здесь решать лучше методом выбора.

1)Дан фрагмент линейного алгоритма.

а:=8

b:=6+3*а

а:=b/3*а

Чему равно значение переменной а после его исполнения?


Ваш ответ:

2)Исполните следующий фрагмент линейного алгоритм для а = х и b = y.

а:=а+b

b:=b-a

а:=а+b

b:=-b

Какие значения присвоены переменным a и b?

а)-у, х
б)y, х
в)х, у
г)х+у, х-у

3)Определите значение целочисленных переменных х и у после выполнения фрагмента программы.

х:=11

у:=5

t:=y

у:=х mod у

x:=t

y:=y+2*t

а)х = 10, у = 5
б)х = 5, у = 11
в)x = 11, y = 5
г)х = 5, у = 10

4)Среди четырёх монет есть одна фальшивая. Неизвестно, легче она или тяжелее настоящей. Какое минимальное количество взвешиваний необходимо сделать на весах с двумя чашками без гирь, чтобы определить фальшивую монету?

а)4
б)2
в)5
с)3

Помогите решить задачи с помощью Паскаля:

1. В массиве все отрицательные элементы переместить в начало массива, а остальные в конец с сохранением порядка следования.
2. Дана последовательность целых чисел, среди чисел есть одинаковые, создать массив различных чисел последовательности и полученный массив отсортировать по возрастанию.

120 БАЛЛОВ!!!

Решить задачу с помощью схемы:

Увлечения.

Витя, Саша, Андрей и Толя собирали модели
самолетов. Двое делали модели из белой пластмассы, а двое – из серой. Саша и Андрей,
Саша и Толя делали модели из пластмассы разного цвета. Получились три модели
самолетов «Ту» и одна – «Су».

Какую модель и из какого
материала делал каждый из мальчиков, если Саша делал модель самолета «Су» из
белой пластмассы



Вы находитесь на странице вопроса "Решить задачи с помощью линейных алгоритмов !", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.