Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Ведущим задумано число в диапазоне от 0 до 1000.Какое минимальное количество вопросов надо задать,чтобы угадать в каком десятке находится число

10-11 класс

(ответы ведущего "больше" или "меньше")

Ариша765 11 авг. 2014 г., 8:35:24 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alice1090
11 авг. 2014 г., 11:00:14 (9 лет назад)

10 вопросов
это способ бинарной сортировки
сначала делим 1000 на 2
задаем вопрос больше или меньше
потом если больше то отрезок будет от 500 до 1000
(1000-500)/2+500=750 -новый вопрос потом еще вопрос
короше так:
A-начала отрезка(сначала A=1)
B-конец отрезка(B=1000)
найдем середину R=(B-A)/2+A-(возмем целое)
потом если больше то A=R иначе B=R
потом так продолжаем до тех пор пока A небудет равнятся B

Ответить

Другие вопросы из категории

Дан фрагмент программы. Нарисуйте блок-схему, восстановите вид формулы для расчета S

PASCAL:

VAR
A:ARRAY[1...100]OFF
INTEGER;
N,I,J: INTEGER;
S: REAL;
BTGIN
N:=8;
FOR I:=1 TO N DO
BEGIN
S:=0;
FOR J:=1 TO I DO
S:=S+(A[J]);
S:=ABS(S);
WRITELN(`S`=`,S:9:2);
END;
READLN;
END.

QBASIC
DEFINT N,I,J,S,
DIM A(100) AS INTEGER
N:=8
FOR I=1 TO N
S=0
FOR J=1 TO I
S=S+A[J]
NEXT J
S=ABS(S)
PRINT S
NEXT I

ШКОЛЬНЫЙ АЯ

алг слово(рез вещ s)
цел раб А[1:100]
n:=8
нц для I от 1 до n
s=0
нц для j от 1 до I
s=s+a[j]
кц
s=abs(s)
вывод s
кц
кон

Пожааалуйста нужны блок-схемы для трех вариантов получения s





Написать программу в Паскале
Задание 4. Установите соответствие Соотнесите каждый термин с его определением (каждое определение может быть использовано не более одного раза). 1.

Доменное имя 2. Домашняя страница 3. «Паук» 4. Универсальный указатель ресурсов 5. Хождение по сети 6. Веб-сайт 7. Общественная собственность A. Бесплатная информация, которая доступна любому пользователю. B. Автоматизированная программа, которая путешествует по Интернет, обнаруживая веб-сайты или определенные веб-страницы, и добавляет их в базовый список. C. Верхняя, первая страница веб-сайта. D. Пролистывание страниц во Всемирной Паутине. E. Группировка похожей информации во Всемирной Паутине, состоящая из индивидуальных веб-страниц. F. Имя сервера, который содержит всю информацию веб-сайта, например, microsoft.com. G. Адрес веб-сайта во Всемирной Паутине, например, http://www.microsoft.com.

Объем свободной памяти на диске 0,01 Гбайт, разрядность звуковой платы 16. Какова будет длительность звучания цифрового фудиофайла, если его запись с

частотой дискретизации 44 100 Гц.

Ребят помогите пожалуйста. Если можно поподробней)))))))))))Пожалуйста))))

Читайте также

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет
1)составьте программу вычисления суммы чисел в диапазоне от 45 до 115 45+....+115

2)Составьте программу которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150
3)Дано вещественное число А и целое число N(>0).Испульзуя один цикл вывести все целые степени числа А от 1 до N

------------------------ОПЕРАТОР WHILE

№1 Вывести на экран квадраты чисел от 1 до n. №2 Вывести на экран таблицу умножения от 1 до 10

числа n.

№3

Вычислить значение факториала n!

№4

В диапазоне от 1 до n вывести все четные числа на экран.

№5

Найти количество чисел, которые делятся на 3 и 5, из диапазона от 1 до n.

помогите коле и напишите программу или алгоритм которое находит все просые числа в диапазоне от m до N ВКлючительно

в задаче требуется написать программу которая по двум заданным числам находила бы в диапазоне между этими числами все простые числам где простое число которое имеет всего лишь два делителя то есть оно делится на единицу и на само себя и больше оно не на что не делиться например -3 7 11 помогите )) олимпиада по инфе )) даю максимум баллов ))

1.При угадывании целого числа в диапазоне от 1 до N было получено 7 бит информации. Чему равно N? 2. При угадывании целого числа в некотором

диапазоне было получено 6 бит информации. Сколько чисел содержит этот диапазон?

тут две задачи. но они подобные.

умоляю!!! решите!! низнаю как!!!



Вы находитесь на странице вопроса "Ведущим задумано число в диапазоне от 0 до 1000.Какое минимальное количество вопросов надо задать,чтобы угадать в каком десятке находится число", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.