Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Составьте программу вычисления значение Sin, Cos и Tg углов от 0 до 45 градусов с шагом 1 градус (с использованием оператора цикла FOR). Для вы-вода

10-11 класс

результата введите ограничение на количество знаков после запятой. Примечание. В Паскале используются стандартные функции: SIN(X) - синус Х (аргумент задается в радианах); COS(X) - косинус Х (аргумент задается в радианах); Для подсчета угла в радианах используйте формулу: угол в радианах = (угол в градусах)*/180. Результат представьте в виде: Программа вычисления значений тригонометрических функций x° Sin(x) Cos(x) Tg(x) 1 2 3 .. 45

СофаДавидюк 17 окт. 2014 г., 7:55:40 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Beleza
17 окт. 2014 г., 10:51:22 (9 лет назад)

uses crt;
var
   x,i:integer;
begin
   clrscr;
   writeln ('X Sin(x) Cos(x) Tg(x)');
   i:=2;
   for x:=0 to 45 do begin
     write (x:2,' ',sin(x*pi/180):0:4,' ',cos(x*pi/180):0:4,' ');
     write (sin(x*pi/180)/cos(x*pi/180):0:4);
     writeln;
     i:=i+1;
     if i=24 then
       begin
         writeln ('Press Enter');
         readkey;
       end;
   end;
   readln;
end.

Ответить

Другие вопросы из категории

Помогите, пожалуйста!

В течение семестра студент А.Магистрантов должен выполнить лабораторные работы письменно и в электронном виде. Среди них – 15 письменных работ. Сообщение о том, что работа должна быть выполнена в электронном виде, несет 4 бита информации. Сколько всего лабораторных работ должен выполнить студент А.Магистрантов?

Упростить выражение. Воспользовавшись равносильностью алгебры высказываний

Задание на логику.Очень нужно!)

Задачи на записи и файлы. № 1. Пусть дан файл целых чисел. Определите длину наибольшего интервала возрастания и среднее арифметическое чисел этого

интервала. № 2. Имеется типизированный файл с числами. Изменить все его элементы, порядковый номер которых кратен трем. Новые значения вводятся с клавиатуры. Размер существующего файла неизвестен.

Читайте также

Помогите пожалуйста!! ) составить программу в "Pascal abc"!!)

Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h.
Результат представить в виде таблицы, первый столбец которой — значения
аргумента, второй — соответствующие значения функции: "F(x) = 1/2 ctg x/4+4"

1. Составьте блок-схему и программу вычисления значения функции:

2. Составьте программу, определяющую, является ли данное число делителем числа 3.
3*. Составьте программу, заменяющую из двух данных чисел меньшее число суммой, а большее – произведением этих чисел.

1)составьте программу вычисления суммы чисел в диапазоне от 45 до 115 45+....+115

2)Составьте программу которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150
3)Дано вещественное число А и целое число N(>0).Испульзуя один цикл вывести все целые степени числа А от 1 до N

------------------------ОПЕРАТОР WHILE



Вы находитесь на странице вопроса "Составьте программу вычисления значение Sin, Cos и Tg углов от 0 до 45 градусов с шагом 1 градус (с использованием оператора цикла FOR). Для вы-вода", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.