Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Определите диапазон целых чисел ,хранящихся в 1 байте памяти в двух вариантах: со знаком и без знака.

10-11 класс

AnnaBraun 07 окт. 2013 г., 8:40:07 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Махабатка
07 окт. 2013 г., 9:55:57 (10 лет назад)

1 байт - 8 бит, следовательно числа -127 до 127.

Ответить

Другие вопросы из категории

Помогите решить массив в паскале,пожалуйста!!!

Дано:массивы А1(N1,M1),A2(N2,M2),A3(N3,M3). Сформировать одномерные массивы В1,В2,В3,каждый из которых состоит из элементов,лежащих в интервале [1,3] массивов А1,А2,А3 соответственно. Формирование одномерного массива,состоящего из элементов исходного массива, лежащих в интервале[1,3], осуществить в подпрограмме.

A B C D E F 1 2 3 1 2 3 4 4 11 13 15 17 5 21 24 27 30 6 31 35 39 43 В ячейке А1 записали формулу

=E$5-SD4. После этого ячейку А1 скопировали в ячейку В2. Какое число будет показано в ячейке В2?

Знак $используется для обозначения абсолютной адресации

1)6

2)14

3)16

4)24

Читайте также

Задание звучит : Дана последовательность целых чисел, за которой следует ноль. Определить, число соседств чисел с одинаковыми знаками.

Что нужно изменить в программе, чтобы выполнялось условие задачи.

Program exapmle2;
var x,y,k:integer;
begin
writeln('Эта программа определяет, число соседств чисел с одинаковыми знаками');
write('Введите число:');
read(x);
y:=x;
k:=0;
while y<>0 do
begin
if x*y<0 then inc(k);
if x*y>0 then inc(k);
y:=x;
read(y);
end;
writeln(' Число соседств ',k);
writeln('нажмите Enter для завершения работы программы');
readln;
end.

Даны два целых числа А и В (А<В). Найти сумму всех целых чисел от А до В включительно Входные данные: ввести два целых числа А,В (1<=A,

B<=100).

Выходнфе данные: вывести сумму всех целых чисел от А до В включительно.

Можно, пожалуйста, с объяснением.

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих

256. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел, не превосходящих 256.



Вы находитесь на странице вопроса "Определите диапазон целых чисел ,хранящихся в 1 байте памяти в двух вариантах: со знаком и без знака.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.