Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

По координатам вершин треугольника вычислите его периметр, используя подпрограмму вычисления длины отрезка между двумя точками.

10-11 класс

Francisc 25 марта 2014 г., 22:20:29 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Fne4ka11
25 марта 2014 г., 23:45:33 (10 лет назад)

var a1,b1,a2,b2,a3,b3:integer;
  p,a,b,c:real;
procedure dlina (x1,x2,y1,y2:integer; var d:real);
 begin
  d:=sqrt(sqr(x2-x1)+sqr(y2-y1));
  end;
begin
 read(a1,b1,a2,b2,a3,b3);
 dlina(a1,a2,b1,b2,a);
dlina(a2,a3,b2,b3,b);
dlina(a3,a1,b3,b1,c);
p:=a+b+c;
write(p:0:2);
end.

Ответить

Другие вопросы из категории

помогите нужно составить программу
1.
Задача 1.
Вы посетили магазин и купили 10 видов товара.В таблицу T[1:10] вы записали количество купленного товара каждого вида.В таблицу C[1:10] записали цены

единиц каждого вида товара соответственно. Составе алгоритм вычисления общей стоимости всех покупок

Читайте также

1. По сторонам треугольника найти его периметр, площадь, высоты и радиус вписанного и описаного кругов.

2. Найти больше из трех данных чисел.
3. В одномерном массиве положительные элементы меншиты на 7.

Дано множество точек с координатами на плоскости.

Написать программу, которая использует подпрограммы и выведит на экран наименьшее расстояние между двумя точками.



Вы находитесь на странице вопроса "По координатам вершин треугольника вычислите его периметр, используя подпрограмму вычисления длины отрезка между двумя точками.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.