Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Рассмотрите запись алгоритма на знакомом в большей степени вам языке. Обратите внимание, что расшифровать надо значение переменных и определить, что

5-9 класс

будет выведено на экран в результате выполнения алгоритма. Необходимо учитывать начальное и конечное значение параметра цикла, начальное значение переменной S.

Определите, что будет напечатано в результате выполнения следуюшего алгоритма, записанного на трёх алгоритмических языках.

Kusya1993 13 июня 2014 г., 21:37:52 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Bbbbbbbaby
13 июня 2014 г., 23:51:08 (9 лет назад)

Тут довольно все просто. Начнем по порядку. Переменная S = 1, а переменная К = 3 и она стремится к 0. За один шаг/ход переменная К уменьшается на единицу. Начнем?

(Дабы постоянно не менять язык переменную S я буду обозначать С (русская С), а то менять язык или вставлять S муторно). 

С=1

К=3

 

 

С=1*3=3 

 

К=3-1=2

 

 

 

С=3*3=9

К=2-1=1

 

 

С=9*3=27 

 

К=1-1=0

 

 По программе мы должны вывести переменную С, следовательно ответ 27

+ 0 -
Tanchiksofik
14 июня 2014 г., 1:50:43 (9 лет назад)

Цикл выполняется 4 раза(К=3,2,1,0)

Каждый раз S умножается на 3, поэтому результат будет

S=1*3*3*3*3 = 81.

 

Ответить

Другие вопросы из категории

Известны размеры двух ящиков(длина, ширина, высота) .Определить объем какого ящика больше . Размеры меньшего ящика увеличить в два раза и снова сравнить

объемы ящиков . Вывести на экран больший объем. Составить программу в паскале.

Известны радиусы и координаты центров двух окружностей таких , что одна окружность не содержит внутри другой . Определить пересекаются ли эти окружности (расстояние между центрами должно быть меньше суммы радиусов). Определит площадь большей окружности. Составить программу в паскале

Читайте также

1). Определите значение переменной a после выполнения данного алгоритма :

b := 8
a := 10
b := b+a*2
a := 29-a
В ответе укажите одно целое число - значение переменной a

2). Переведите число 1101011 из двоичной системы счисления в десятичную систему счисления. В ответе напишите полученное число.

3). У исполнителя Удвоитель две команды, которым присвоены номера :
1. умножь на 2
2. прибавь 3
Первая из них увеличивает число на экране в 2 раза, вторая - прибавляет к числу 3.

Составьте алгоритм получения из числа 4 числа 47, содержащий не более 5 команд. В ответ запишите норма команд.

1.Какое значение переменной S будет напечатано после выполнения фрагмента программы,записанной на языке программирования TURBO PASCAL:A:=2В: = 3;

if A>B then S: = A+B;
writeln (S);
Варианты ответов:1)5 ;2)6; 3)7; 4)8

2. Какое значение переменной S будет напечатано после выполнения фрагмента программы, записанной на языке программирования PASCAL:
S: =1;
N: =1;
while N<=3 do
begin
S: = S*N;
N: = N+1;
end;
writeln(S);
Варианты ответов: 1)2 ; 2)1; 3)0; 4)4

Задание1. Значение переменной Х ввести с клавиатуры. Переменной У присвоить значение 5. Вывести на экран информацию «знач.Х»+5=

«итог. сумма».

Задание 2.

Переменной Х присвоить значение 7. Переменной Р присвоить значение, равное квадрату Х. Вывести значения переменных Х и Р (через запятую). Значение Х увеличить на Х. Переменной Р присвоить значение, равное корню квадратному из Х. Вывести значения переменных Х и Р (через запятую).

DIKTANT 2

Задание 1.

Значение переменной Х присвоить в программе. При неотрицательном значении Х переменной У присвоить значение, равное корню квадратному из Х. В противном случае, переменной У присвоить значение, равное квадрату Х. Вывести на экран значение Х и значение У.

Задание 2.

Двум произвольным переменным присвоить произвольным образом соответственно 2 числа. Двум другим переменным присвоить значения, равные тангенсам двух предыдущих переменных. Вывести на экран значения всех переменных, а так же сумму значений двух последних переменных. помогите сделать пож

Отдаю последние баллы!

Переменные а и b описаны в программе как целочисленные. Определите значение переменной а после выполнения следующего фрагмента программы:
a:=374;
b=div(a,100);
a:=mod(a+b,10);
a:=a*b
где dim и mod функции, вычисляющие результат деления нацело первого аргумента на второй и остаток от деления соответственно.
В ответе укажите одно число - значение переменной а
Желательно с решением!



Вы находитесь на странице вопроса "Рассмотрите запись алгоритма на знакомом в большей степени вам языке. Обратите внимание, что расшифровать надо значение переменных и определить, что", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.