Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Паскаль.Даны действительные положительные числа x ,y .Меньшее из этих двух чисел заменить их полу суммой, а большее их удвоенным произведением.

10-11 класс

Nhyfdssdfv 16 июля 2014 г., 7:58:46 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Irimka2002
16 июля 2014 г., 10:12:39 (9 лет назад)

Вот так?:

 

Program solution;
Uses Crt;
Var x, y, t : real;

begin
clrscr;
write('x, y: ');
readln(x, y);

if x > y then
        begin
        t := y;
        y := (x + y) / 2;
        x := 2 * x * t;
        end
else
        begin
        t := x;
        x := (x + y) / 2;
        y := 2 * t * y;
        end;

write('x = ', x : 0 : 4, '; y = ', y : 0 : 4);

readkey;
End.

Ответить

Другие вопросы из категории

Читайте также

Помогите с задачками в паскале. Даны три положительных числа а, в, с. Проверить будут ли они сторонами треугольника. Если да то

вычислить площадь этого треугольника. Даны два действительных положительных числа х и у. Арифметические действия над числами пронумерованы (1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление). Составить программу, которая по выведенному номеру выполняет то или иное действие над числами.

Дано целое положительное число. Проверить истинность высказывания: «данное число является нечетным трехзначным».

Входные данные: ввести одно целое положительное число a ((1<=a<=1000).
Выходные данные: вывести слово «true» если приведенное высказывание для предложенных исходных данных является истинным или «false» в противном случае.

Составить программу для решения задачи: 1)Даны действительные, положительные числа x,y,z. Выяснить, существует ли треугольник с длинами сторон x,y,z. Если

треугольник, то является ли он равносторонним? 2)Дан одномерный массив. Найти количество смен знака между соседними элементами массива. Программа -Паскаль.

Помогите, пожалуйста(Паскаль):

Даны действительные положительные числа x



Вы находитесь на странице вопроса "Паскаль.Даны действительные положительные числа x ,y .Меньшее из этих двух чисел заменить их полу суммой, а большее их удвоенным произведением.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.