Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Разработать алгоритм в массиве В (1:4,1:4) определить сумму элементов главной диагонали

10-11 класс

Pussy123 15 марта 2015 г., 18:35:53 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Anytka0608
15 марта 2015 г., 19:38:20 (9 лет назад)

uses crt;
var i,s,j:integer;
a:array[1..4,1..4] of integer;
begin
randomize;
s:=0;
for i:=1 to 4 do begin
for j:=1 to 4 do a[i,j]:=random(50)+1;
end;
for i:=1 to 4 do begin writeln;
for j:=1 to 4 do begin
write(a[i,j],' ');
end;
s:=s+a[i,i];
end;
writeln;
writeln('s= ',s);
readln;
end.

Ответить

Другие вопросы из категории

Решети задачу Модем передаёт информацию со скоростью 29 к бит/с Надо передать 3 документа . Объём документов 1.) 380000 байт

2.) 5 листов по 100 символов (16 бит код)

3.) 0.75 мбайт

За какое время 7 (сек.мин )

загадки к слову телефон
пассажир не знает,какой(только один) из 8 поездов,стоящих на вокзале,ппассажир не знает,какой(только один) из 8 поездов,стоящих на

вокзале,проследует в Санкт-Петербург.В справочном бюро он задаёт 8 вопросов:Поезд на первой платформе проследует в Санкт-Петербург?
Поезд на 2 платформе проследует до Питера? И т.д на первые 7 вопросов он получил ответ нет! А на последний да.пассажир считает считает что он получил 8 битов информации.прав ли он или нет?почему

Читайте также

Паскаль. 12.Дан массив А(3*4). Найти сумму первых отрицательных элементов в каждом столбце. 13.Даны два массива А(3*3)

и В(3*3). Вывести на экран тот из них, у которого меньше сумма элементов главной диагонали.

17.Дан массив А(3*4). Заменить все отрицательные элементы на противоположные.

Составить программу, которая вычисляет сумму элементов главной диагонали в

двумерном массиве размерности 3х3. Заполнить массив целыми случайными числами из
диапазона от 0 до 15.

ЛБ- 70 Разработайте алгоритм для вычисления площади треугольника: s = 1/2ah, где а – длина основания треугольника, h – его высота.

ВБ- 71 Разработайте схему алгоритма, который проверяет, не превосходит ли сумма двух действительных чисел А и В числа 100. Если не превосходит, установить значение флага F=0, иначе установить значение флага F=1. Вывести значение F.

ЦА-10 Разработайте схему алгоритма для вычисления суммы S первых n целых чисел. Предусмотрите ввод значения n с клавиатуры. Текущее значение целого числа имеет имя i (i = 1, 2, .., n).

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.



Вы находитесь на странице вопроса "Разработать алгоритм в массиве В (1:4,1:4) определить сумму элементов главной диагонали", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.