Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

доброго времени суток.) кто-нибудь может помочь?ибо я совсем не вывожу информатику. 1.Написать программу, которая вводит массив из N целых чисел

5-9 класс

и выводит на экран элементы с чётными номерами. Протестировать программу на произвольных массивах размерностью 5 и 8 элементов.

2..Написать программу, которая вводит массив из N целых чисел и выводит на экран сам массив и сумму всех его элементов. Протестировать программу на следующих массивах:
а) 1 3 4 -2
б)0 1 -2 10 11 12 -10 -3
в)1 1 1 1 -1 -1 -1 -1
очень прошу-у-у, уделите время, если Вас не затруднит.

Cheremshenko 25 апр. 2016 г., 5:17:52 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Evsikovae
25 апр. 2016 г., 6:43:51 (7 лет назад)

1)

var a:array [1..100] of integer; объявляем массив

i,n:byte; объявляем вспомогательную переменную i и переменную  n  для хранения количества элементов

 

begin

write('Введите n = ');readln(n); вводим n

for i:=1 to n do begin от 1 до n  цикл 

write('a[',i,']=');

readln(a[i]); вводим элементы в массив

end;

write('Исходный массив: ');

for i:=1 to n do выводим наш массив полностью

write(a[i],' ');

writeln;

write('Результат: '); выводим результат, в данном случае все элементы стоящие на четных местах

for i:=1 to n do

if i mod 2 =0 then write(a[i],' '); проверка на четность, мод - это оператор деления по остатку, если индекс делится на 2 без остатка, то выводим элемент

end.

 

2)

var a:array [1..100] of integer;

i,n:byte; s:longint; s объявляем для хранения суммы элементов

 

begin

s:=0; обнуляем s

write('Введите n = ');readln(n);  тут тоже самое, что и в первой задаче

for i:=1 to n do begin

write('a[',i,']=');

readln(a[i]);

s:=s+a[i]; вот здесь мы складываем каждый элемент массива в переменную s

end;

write('Исходный массив: ');

for i:=1 to n do  вывод массива

write(a[i],' ');

writeln('Сумма всех элементов массива = ',s); вывод суммы

end.

 

Удачи=)

Ответить

Другие вопросы из категории

1)Текст составлен с использованием алфавита мощностью 64 символа и содержит 100 символов .Каков информационный объём текста?

2)Информационный объём текста,подготовленного с помощью компьютера,равен 3,5Кб.Сколько символов содержит этот текст?
3)Два текста содержат одинаковое количество символов.Первый текс составлен в алфавите мощностью 32 символа,второй =мощьностью 64 символа.Во сколько раз отличаются информационные объёмы этих текстов?

Внесите исправления в приведённый ниже алгоритм, чтобы в результате его работы была нарисована рамка вдоль границ

поля (исходное положение графического исполнителя – произвольное) и алгоритм не зацикливался:

ПЕРЕХОД

Поворот

ПЕРЕХОД

Поворот

Пока впереди не край

нц

ЛИНИЯ

Поворот

кц

Процедура ПЕРЕХОД

пока впереди край повторять

нц

прыжок

кц

конец процедуры

Процедура ЛИНИЯ

Пока впереди не край повторять

нц

шаг

кц

конец процедуры

Читайте также

Помогите плиз срочно 1)Написать программу,которая спрашивает"Который час?" и,в зависимости от введенного времени,выводит приветствие:"Доброе

утро","Добрый день","Добрый вечер", "Спокойной ночи". 2)Написать программу,которая определяет,принадлежит ли точка с координатами (x,y)Заштрихованной области,ограниченной точками(x1,y1)(x2,y2).

Помогите Решить 4 любые задачи:

1)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Сколько элементов последовательности превышает число 100?
2)Вводится последовательность из 10 вещественных чисел. Вычислить сумму элементов, не превышающих числа А.
3)С клавиатуры вводится последовательность из 7 целых чисел. Определить каких чисел больше: четных или нечетных.
4)С клавиатуры вводится последовательность из 9 чисел. Найти разность между макимальным и минимальным элементами.
5)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Найти порядковый номер отрицательного элемента, если считать элементы справа. В случае нескольких отрицательных элементов вывести номер последнего из них (т.е. самого правого).
6)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Найти порядковый номер первого двузначного элемента последовательности, считая элементы в прямом порядке.
7)С клавиатуры вводится последовательность положительных чисел, оканчивающаяся 0. Найти сумму двузначных элементов последовательности.
8)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Найти произведение отрицательных элементов последовательности.
9)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Найти в ней минимальный элемент.
10)С клавиатуры вводятся числа 2, 5 или 10, означающие удаления игроков на соответствующее кол-во минут. Условно положительные значения означают удаления в команде А, а отрицательные - в команде В. Для завершения ввода данных используется 0. Сколько всего штрафного времени заработано командами А и В отдельно, а также определить общее штрафное время.

Привет всем. в понедельник экзамен по информатике, а я ничего не могу решить. кто нибудь может помочь?

задачи:
1.Найдите сумму всех элементов одномерного числового массива.
2.найдите произведение всех элементов одномерного числового массива.
3.найдите количество отрицательных элементов одномерного числового массива.
4.найдите количество нечетных элементов одномерного числового массива.
5.найдите количество элементов одномерного числового массива <20.
6.найдите количество кратных 7 элементов одномерного числового массива.
7.найдите сумму элементов одномерного числового массива=8.
8.найдите сумму кратных 11 элементов одномерного числового массива.
9.найдите сумму чётных элементов одномерного числового массива.
10.найдите произведение кратных 3 элементов одномерного числового массива.
11.найдите произведение элементов одномерного числового массива >2 и <5.
12.вывести на экран элементов одномерного числового массива >15.
13.вывеси на экран элементов одномерного числового массива кратных 21.
14.вывести на экран четные элементов одномерного числового массива.

1. Написать программу, которая спрашивает «Который час?» и, в зависимости от введенного времени, выводит на экран приветствие: «Доброе утро», «Добрый

день», «Добрый вечер», «Спокойной ночи».
2. Составьте программу, которая вычисляет оптимальный вес пользователя, сравнивает его с реальным весом и выдает рекомендации о необходимости поправиться или похудеть. Оптимальный вес вычисляется по формуле: рост (в сантиметрах) – 100.
Помогите решить 2 задачи

1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива.

2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива.
3. Массив из 5 целых чисел вводится с клавиатуры в строку. Найти сумму элементов массива, стоящих на чётных позициях. Вывести исходный массив и полученную сумму.
4. Массив из 40 целых чисел из промежутка [10,90] задается с помощью генератора случайных чисел. Найти сумму элементов массива, кратных n . Вывести исходный массив и полученную сумму.
Помогите кто в чем может.



Вы находитесь на странице вопроса "доброго времени суток.) кто-нибудь может помочь?ибо я совсем не вывожу информатику. 1.Написать программу, которая вводит массив из N целых чисел", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.