Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Чему будет равно значение s после выполнения фрагмента программы:

5-9 класс

A: array [1..10] of integer=(2, 3, 6, 4, 1, 3, 0, 0, 2, 1);
..............
s:=1
for i:=1 to 10 do
if a[i] mod 3=0 then s:=s+a[i]

Larry691 16 нояб. 2013 г., 15:42:38 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dachakazakovvva
16 нояб. 2013 г., 17:57:35 (10 лет назад)

Ответ: 13

за цикл мы смотрим, чтобы деление на три было равно (по остатку) нулю.
Таких чисел 3 - 3, 6, 3.

3 + 3 + 6 + 1 = 13

Ответить

Другие вопросы из категории

-Информационное сообщение объемом 1,5 Кбайта содержит 3072 символа. Сколько символов содержит алфавит, при помощи которого было записано это сообщение?

-Для записи текста использовался 256-символьный алфавит. Каждая страница содержит 30 строк по 70 символов в строке. Какой объем информации содержат 5 страниц текста?

Переведите координаты точек из двоичной системы счисления в десятичную!

1(0,101) 2(10,110) 3(110,100) 4(1001,110)
5(1010,1101) 6(1010,1110) 7(1011,1111) 8(1100,1111)
9(1101,1110) 10(1101,1101) 11(1100,1100) 12(1011,1100)
13(1010,1101) 14(1001,110) 15(1101,101) 16(1111,0)
17(10001,1) 1(110,1010) 2(1000,1100) 3(1010,1011)
4(1101,1001) 5(1111,1011) 6(1100,1110)

закодировать значение числа в двоичную систему а)число 117 б)число 217 в) число 317

женя готовил доклад по литературе. в докладе 12 строчек,в каждой строчке 22 символа. определить количество информации а)в 1 символе 7 бит б) в 1 символе 10 разрядов двоичного кода.
пожалуйста помогите

Читайте также

1.Какое значение переменной S будет напечатано после выполнения фрагмента программы,записанной на языке программирования TURBO PASCAL:A:=2В: = 3;

if A>B then S: = A+B;
writeln (S);
Варианты ответов:1)5 ;2)6; 3)7; 4)8

2. Какое значение переменной S будет напечатано после выполнения фрагмента программы, записанной на языке программирования PASCAL:
S: =1;
N: =1;
while N<=3 do
begin
S: = S*N;
N: = N+1;
end;
writeln(S);
Варианты ответов: 1)2 ; 2)1; 3)0; 4)4

1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a := 3 + 8*4; b :=

(a div 10) + 14;

a := (b mod 10) + 2;

2) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 1819;

b := (a div 100)*10+9;

a := (10*b–a) mod 100;

3) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 42;

b := 14;

a := a div b;

b := a*b;

a := b div a;

4) Определите значение целочисленных переменных x, y и t после выполнения фрагмента программы:

x := 5;

y := 7;

t := x;

x := y mod x;

y := t;

5) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

а :=6*12 + 3;

b :=(a div 10)+ 5;

a :=(b mod 10)+ 1;

Сколько раз будет выполняться цикл

for i:=7 to 12 do...;
Чему будет равна переменная s после выполнения фрагмента программы
s:=40;
for i:=15 to 19 do
s:=s+1
Дан шаблон цикла
forx:=M downto N do begin...end;
Чему равен шаг цикла?
Помогите пожалуйста

Какое значение будет принемать значение Y после выполнения фрагментов программы: 1. var x,y: INTEGER; BEGIN y:=0; for x:=1

to 9 do

y:=y+x;

writeln(y=,y);

END.

2.var x,y: INTEGER;

BEGIN

y:=0;

for x:=10 downto 5 do

y:=y+1

writeln(y=,y);

END

3. var x,y: INTEGER;

BEGIN

y:=1;

x:=15;

while x>5 do

begin

x:=x-3;

y:=y*x;

end;

writeln(y=,y)

END.

4. var x,y: INTEGER;

begin

y:=1;

x:=10;

repeat

y:=y*x+x;

x:=x-2;

until x<0;

writeln(y=,y);

end.

пожалуйста напишите подробное решение и как получаются ответы



Вы находитесь на странице вопроса "Чему будет равно значение s после выполнения фрагмента программы:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.