Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Массив В задан случайным образом а) подсчитать сумму элементов массива, меньших своего номера; б) подсчитать сумму элементов массива, стоящих на четных

5-9 класс

местах; в) подсчитать сумму отрицательных элементов массива; г) подсчитать сумму элементов массива, больших произвольного числа К. помогите, пожалуйста

Anjelaarm 25 дек. 2014 г., 0:05:53 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
кіся12
25 дек. 2014 г., 2:33:34 (9 лет назад)

Пример на Паскале. Пусть массив размером 100 элементов

Program Maasiv;

var A:array[1..100] of real; i,s:integer; k :real;

begin

random;

For i:=1 to 100 do A[i]:=randomize(100)-50; {заполняем массив случайными числами от -50 до 50}

s:=0; for i:=1 to 100 do if A[i]<i then S:=S+A[i]; writeln(s);{задание а}

s:=0; for i:=1 to 100 do if i/2=int(i/2) then S:=S+A[i]; writeln(s);{задание б}

s:=0; for i:=1 to 100 do if A[i]<0 then S:=S+A[i]; writeln(s);{задание в}

readln(k);s:=0; for i:=1 to 100 do if A[i]>k then S:=S+A[i]; writeln(s);{задание г}

end.

 

 

 

 

 

 

 

Ответить

Читайте также

Заполните массив с клавиатуры целыми числами и найдите сумму элементов массива с i1-го по i2-й (i1 и i2 вводить с клавиатуры).

Входные данные:
в первой строке целое число n (0 < n ≤ 100) - кол-во элементов в массиве и целые числа i1 и i2 (0 < i1, i2 ≤ 100). Во второй строке целые числа Х1, Х2,..,Хn разделенные пробелом (числа по модулю не превосходят 32000) - значения элементов массива.

Выходные данные:
сумма элементов массива c номерами от i1 до i2.

(Написать программу на Паскале)

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

1)Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2)Задан массив из 11 целых чисел. Посчитать количество нечётных

элементов массива.

3)задан массив из 9 целых чисел.Вывести на экран чётные элементы

1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива.

2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива.
3. Массив из 5 целых чисел вводится с клавиатуры в строку. Найти сумму элементов массива, стоящих на чётных позициях. Вывести исходный массив и полученную сумму.
4. Массив из 40 целых чисел из промежутка [10,90] задается с помощью генератора случайных чисел. Найти сумму элементов массива, кратных n . Вывести исходный массив и полученную сумму.
Помогите кто в чем может.



Вы находитесь на странице вопроса "Массив В задан случайным образом а) подсчитать сумму элементов массива, меньших своего номера; б) подсчитать сумму элементов массива, стоящих на четных", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.