Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Введите трехзначное число и выведите среднюю цифру. (Пояснение: Примените операции div и mod)

5-9 класс

Dasha020705 03 окт. 2015 г., 17:44:54 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kate20020224
03 окт. 2015 г., 18:30:55 (8 лет назад)

var a:integer;

begin

readln(a);

writeln((a div 10) mod 10);

end.

Ответить

Другие вопросы из категории

ОЧЕНЬ НАДО! ПОМОГИТЕ!!!!!! Текстовый документ, состоящий из 1026048 символов, хранился в 8-битной кодировке КОИ-8. Этот документ был преобразован в

16-битную кодировку Unicode. Укажите, какое дополнительное количество Кбайт потребуется для хранения документа. В ответе запишите только число.

Читайте также

Введите целое число и найти сумму его цифр.

Пример:
Введите целое число:
1 2 3 4
Сумма цифр числа 1 2 3 4 равна 10

1. Если дано трехзначное число, например 123 его можно представить в

виде 3+2*10+1*10*10. Воспользовавшись этой информацией, создайте программу,
которая, получая от пользователя трехзначное число, будет определять из каких цифр
оно состоит и выводить их через пробел (например, 1_2_3).

Дано трехзначное число. напишите программу, которая определяет:

1) есть ли среди цифр заданного трехзначного числа одинаковые;
Пример входных данных
123 нет
121 да
222 да

2) является ли число '' перевертышем" , т.е. числом , десятичная запись которого читается одинаково слева направо и справа налево.
Пример входных данных
122 нет
121 перевертыш
222 перевертыш

Пожалуйста с примером!!!
Заранее большое спасибо

В трехзначном числе x зачеркнули его вторую цифру. Когда к

образовавшемуся двухзначному числу справа приписали вторую цифру числа x, то получилось число n. По заданному n найти число x
(значение n вводится с клавиатуры).



Вы находитесь на странице вопроса "Введите трехзначное число и выведите среднюю цифру. (Пояснение: Примените операции div и mod)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.