Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

напечатать на экран сумму чисел, находящиеся в числовом диапазоне [-100; 1000] которые не четны и отрицательны. сделать блок-схему

5-9 класс

Zybkovas 29 марта 2017 г., 15:25:14 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
MariNikkk
29 марта 2017 г., 17:59:49 (7 лет назад)

я не очень уверена на счет оформления, ибо пишу обычно в паскале программы, а со схемами редко работаю. но суть такая:

+ 0 -
Abubakir
29 марта 2017 г., 20:21:04 (7 лет назад)

var a: array [-100..10000] of longint;    

i, n: longint; begin read (n);     

for i:=1 to n do     

read (a[i]);          

for i:=1 to n do         

if (a[i] mod 2=0) and (a[i]<0) then write (a[i], ' ');

end.

Ответить

Другие вопросы из категории

управлять компьютером можно, выбирая нужную команду из заранее заготовленных вариантов - это.... Программы - основной пункт...

Прямоугольная область на экране монитора,которую занимает работающая программа,называется...

(продолжите предложения)

1) сколько будет 2+2x4=?

2)100x1+10x100=?

Читайте также

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.


Паскаль абс 2 задачи 1)Написать программу выводящую на экран последовательность чисел от 1 до 10 через пробел в строчку.

2)Написать программу которая бы выводила на экран произведение нечетных чисел от 10 до 20.

1 Задание:сформируйте и выведите на экран массив из девяти элементов,каждые три последовательных элемента которого составлены по следующему правилу:

1-й равен значению текущего индекса, увеличенному на 3; 2-й равен квадрату предыдущего индекса; 3-й равен сумме двух предыдущих элементов. 2 Задание : сформируйте массив, содержащий 15 элементов ,с помощью датчику случайных чисел. Получите новый массив,каждый элемент которого равен сумме соответствующего элемента исходного массива и его индекса. В полученном массиве удвойте элементы,которые меньше заданного с клавиатуры числа А,и найдите их сумму . Выведите на экран исходные и полученные результаты .

Помогите срочно! Паскаль. Для продажи книг в магазине используется компьютер. Составте программу, которая по стоимости книги и сумме денег, внесенной

покупателем, выводит на экран сумму причитающейся сдачи,если денег внесено больше.Если сдачи не требуется, программа выводит на экран " Спасибо !".



Вы находитесь на странице вопроса "напечатать на экран сумму чисел, находящиеся в числовом диапазоне [-100; 1000] которые не четны и отрицательны. сделать блок-схему", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.