Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

В некотором вузе абитуриенты проходили предварительное тестирование, по результатам которого они могут быть допущены к сдаче вступительных экзаменов в

10-11 класс

первом потоке. Тестирование проводится по трём предметам, по каждому предмету абитуриент может набрать от 0 100 баллов. При этом к сдаче экзаменов в первом потоке допускаются абитуриенты, набравшие по результатам тестирования не менее 30 баллов по каждому из трёх предметов, причём сумма баллов должна быть не менее 140. На вход программы подаются сведения о результатах предварительного тестирования. Известно, что общее количество участников тестирования не превосходит 500. В первой строке вводится количество абитуриентов, принимавших участие в тестировании, N. Далее следуют N строк, имеющих следующий формат: <Фамилия> <Имя> <Баллы> Здесь <Фамилия> – строка, состоящая не более чем из 20 символов; <Имя> – строка, состоящая не более чем из 15 символов, <Баллы> – строка, содержащая два целых числа, разделенных пробелом – баллы, полученные на тестировании по каждому из трёх предметов. При этом <Фамилия> и <Имя>, <Имя> и <Баллы> разделены одним пробелом. Пример входной строки: Романов Вельямин 48 39 55 Напишите программу, которая будет выводить на экран фамилии и имена абитуриентов, допущенных к сдаче экзаменов в первом потоке. При этом фамилии должны выводиться в алфавитном порядке.

Yula38 26 июня 2013 г., 12:51:16 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Stanislavhikt
26 июня 2013 г., 13:22:29 (10 лет назад)

uses crt;
type oc=record
       per,bt,tr:integer;
end;
ab=record
fam,im:string;
ocen:oc;
end;
var b:array [1..50] of ab;
l:ab;
i,n,g,k,h:integer;
begin
clrscr;
writeln ('введи количество абитуриентов');
readln (n);
Writeln ('Вводи фамилии, имена и 3 оценки');
for i:=1 to n do
with b[i] do
begin
readln (fam);
readln (im);
readln (ocen.per,ocen.bt,ocen.tr);
end;
clrscr;
for j:=1 to n do
for i:=1 to n-1 do
if b[i].fam>b[i+1].fam then
begin
l:=b[i];
b[i]:=b[i+1];
b[i+1]:=l;
end;
writeln ('Список всех аббитуриентов:');
for i:=1 to n do
writeln (b[i].fam,' ',b[i].im,' ',b[i].ocen.per,' ',b[i].ocen.bt,' ',b[i].ocen.tr);
writeln ('Список допущенных аббитуриентов');
for i:=1 to n do
with b[i] do
begin
with ocen do
if (per>30) and (bt>30) and (tr>30) and (per+bt+tr>140) then writeln (fam,' ',im,' ',ocen.per,' ',ocen.bt,' ',ocen.tr);
end;
readln;
end.

Ответить

Другие вопросы из категории

Помогите решить!!! Пожалуйста
Виновник дорожно-транспортного происшествия скрылся с места аварии. Первый из опрошенных свидетелей сказал работникам ГИБДД, что это была "Audi", первая

цифра номера машины – единица. Второй свидетель сказал, что машина была марки "BMW", а номер начинался с семерки. Третий свидетель заявил, что машина была "Mazda" номер начинался не с единицы. При дальнейшем расследовании выяснилось, что каждый из свидетелей правильно указал либо только марку машины, либо только первую цифру номера. Какой марки была машина и с какой цифры начинается номер? пожалуйста можно с решением

Что из нижеперечисленного в общем случае в состав центрального процессора?

1. Шина данных
2. счетчик команд
3. кэш
4.материнская плата
5.оперативная память
6.системная шина

Читайте также

Помогите решить на с++ или pascale срочно

Таймер - это часы, которые умеют подавать звуковой сигнал по прошествии некоторого периода времени. Напишите программу, которая определяет, когда должен быть подан звуковой сигнал.Входные данныеВ первой строке входного файла INPUT.TXT записано текущее время в формате ЧЧ:ММ:СС (с ведущими нулями). При этом оно удовлетворяет ограничениям: ЧЧ - от 00 до 23, ММ и СС - от 00 до 60.Во второй строке записан интервал времени, который должен быть измерен. Интервал записывается в формате Ч:М:С (где Ч, М и С - от 0 до 109, без ведущих нулей). Дополнительно если Ч=0 (или Ч=0 и М=0), то они могут быть опущены. Например, 100:60 на самом деле означает 100 минут 60 секунд, что то же самое, что 101:0 или 1:41:0. А 42 обозначает 42 секунды. 100:100:100 - 100 часов, 100 минут, 100 секунд, что то же самое, что 101:41:40.

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!

Все ученики старших классов (с 9-го по 11-й) участво­вали в

школьной спартакиаде. По результатам соревнований каждый из них получил
от 0 до 3-х баллов. На диаграмме I отражено распределение учеников по
клас­сам, а на диаграмме II — количество учеников, набравших бал­лы от 0
до 3-х. На обеих диаграммах каждый ученик учтён толь­ко один раз.

Имеются четыре утверждения:

1 ) Среди учеников 9-го класса есть хотя бы один, набравший 2 или 3 балла.
2 ) Все ученики, набравшие 0 баллов, могут быть 9-классниками.
3 ) Все 10-классники могли набрать ровно по 2 балла.
4 ) Среди набравших 3 балла нет ни одного 10-классника.
Какое из этих утверждений следует из анализа обеих диа­грамм?

при поступлении в вуз абитуриенты получившие двойку на первом экзамене ко второму не допускаются. в массиве A[n] записаны оценки экзаменующихся,полученные

на первом экзамене. подсчитать, сколько человек не допущено ко второму экзамену .В Turbopascal



Вы находитесь на странице вопроса "В некотором вузе абитуриенты проходили предварительное тестирование, по результатам которого они могут быть допущены к сдаче вступительных экзаменов в", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.