Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дан массив из 16 целых чисел, случайно заданных в диапазоне от 0 до 70. Получить max(a1*a16*,a2*a15,...,a8*a9*).

5-9 класс

Drako1 15 июля 2013 г., 14:27:11 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ainurzhan99
15 июля 2013 г., 17:25:55 (10 лет назад)

Program Pr1;
uses crt;
var mas:array[1..16] of integer;
max:array[1..8] of integer;
i,b,c:integer;
Begin
clrscr;
randomize;
b:=0;
for i:=1 to 16 do mas[i]:=random(71);
for i:=1 to 16 do write(mas[i]);
for i:=1 to 16 div 2 do begin
max[i]:=mas[i]*mas[16-b];
b:=b+1;
end;
writeln();
for i:=1 to 8 do write(max[i]);
end.

Ответить

Другие вопросы из категории

Читайте также

1)Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2)Задан массив из 11 целых чисел. Посчитать количество нечётных

элементов массива.

3)задан массив из 9 целых чисел.Вывести на экран чётные элементы

Составьте программу (в Pascal) "Угадай". Программа задумывает случайное число в диапазоне от 0 до 99.

Программа задумывает случайное число в диапазоне от 0 до 99. После каждой попытки играющего прога выводит сообщение "больше", "меньше", "угадано". Дается 10 попыток. Программа завершается, если дан правильный ответ или попытки закончились.

1. Разработать схему алгоритма, который вводит массив из N целых

чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.

2. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с чётными номерами. Протестировать алгоритм на произвольных массивах размерностью 5 и 8 элементов.

3. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с нечётными номерами в обратном порядке. Протестировать алгоритм для следующих исходных данных:

а) 1 3 5 6 8 9

б) -1 4 6 2 4 6 8 6 9

P.S. Убедительная просьба написать решение целиком и до наступления ночи. Я являюсь дилетантом в Паскале, а эти три задачи являются моим домашним заданием по информатике на завтра.

1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива.

2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива.
3. Массив из 5 целых чисел вводится с клавиатуры в строку. Найти сумму элементов массива, стоящих на чётных позициях. Вывести исходный массив и полученную сумму.
4. Массив из 40 целых чисел из промежутка [10,90] задается с помощью генератора случайных чисел. Найти сумму элементов массива, кратных n . Вывести исходный массив и полученную сумму.
Помогите кто в чем может.

Дан массив из N целых чисел a1,a2...,aN.Вам нужно проверить,есть ли в этом массиве три числа сумма которых равно нулю.

Формат входных данных

В певой строке входного файла содержится одно целое число n(1<=n<=200).Во второй строке находятся n целых чисел a1,a2...aN (-1000<=ai<=1000)-елементы массива.

Формат выходных данных

В единственной строке выходного файла выведите одно слово "YES",если в этом массиве есть три числа сумма которых равна нулю.Иначе выведите "NO".



Вы находитесь на странице вопроса "Дан массив из 16 целых чисел, случайно заданных в диапазоне от 0 до 70. Получить max(a1*a16*,a2*a15,...,a8*a9*).", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.