Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

даны два действительных числа. если первое число меньше или равно второму, то первое число заменяется нолем

10-11 класс

в Паскаль ABC
помогите пожалуйста.

Kumiskulmagamb 24 мая 2013 г., 19:06:12 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
маришикс
24 мая 2013 г., 21:59:34 (10 лет назад)

var 
a, b: real;
begin 
readln(a, b); 
if (a <= b) then   
 a := 0;
end.

+ 0 -
Natapta
24 мая 2013 г., 23:07:08 (10 лет назад)

Var  сh1, ch2: real;
begin 
readln(ch1, ch2); 
if (ch1 <= ch2) then   
ch1 := 0;
end.

Ответить

Читайте также

Составьте программу для решения следующей задачи. Введите с клавиатуры два числа: N и M. Если оба числа больше 100, то замените каждое из них меньшим и

выведите результаты на экран. Если первое число положительное, а второе отрицательное, то уменьшите их в два раза и выведите результаты. Иначе, найдите и выведите среднее арифметическое этих чисел.

ПОМОГИТЕ ПОЖАЛУЙСТА!!!! Составьте программу для решения следующей задачи. Введите с клавиатуры два числа: N и M. Если оба числа больше 100, то замените

каждое из них меньшим и выведите результаты на экран. Если первое число положительное, а второе отрицательное, то уменьшите их в два раза и выведите результаты. Иначе, найдите и выведите среднее арифметическое этих чисел.

Сумма цифр. Даны два числа А и В. Подсчитайте кол-во натуральных чисел на отрезке от А до В , сумма цифр которых четна. Программа

получает на вход два натуральных числа А и В, не превосходящих 10^9^ А<=В . Программа должна вывести одно число - кол-во натуральных чисел, больше или равных А и меньших или равных В, сумма цифр которых четна.

написать функцию,сравнивающую две даты.функция должна возвращать(-1) если первая дата меньше второй ,0- если первая и вторая даты одинаковы и 1

-если первая дата больше второй.паскаль.тема записи
в чем ошибка??
type date = record day: 1..31; month: 1..12; year: integer ; end;
var a: date := (day: 1; month: 4; year: 2015); b: date := (day: 1; month: 4; year: 2014); c:integer;

procedure OutDate(d: date);begin with d do writeln(day, '.', month, '.', year);end;
function Srawn(x, y: date): -1..1;beginif x.year > y.year then writeln( 1) else writeln(-1) ; if x.year = y.year then if x.month > y.month then writeln(1) else writeln(-1); if x.year = y.year then if x.month = y.month then if x.day > y.day then writeln(1) else writeln(-1); if x.year = y.year then if x.month = y.month then if x.day = y.day then writeln(0); end; begin OutDate(a); OutDate(b); c:=srawn(a,b); writeln('otwet:', c);end.



Вы находитесь на странице вопроса "даны два действительных числа. если первое число меньше или равно второму, то первое число заменяется нолем", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.