Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Дана строка-предложение. Зашифровать ее, поместив вначале все символы, расположенные на четных позициях строки, а затем, в обратном порядке, все

10-11 класс

символы, расположенные на нечетных позициях.

Repytwjdgfif198 21 июля 2014 г., 17:27:57 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Didenkoqwert
21 июля 2014 г., 20:14:20 (9 лет назад)

var a, b, c, i, n :integer;
     s, p:string;
begin
   readln (s);
   for i:=1 to length (s) do
      if i mod 2 = 0 then p:=p+s[i];
   for i:=length (s) downto 1 do
      if i mod 2 <> 0 then p:=p+s[i];
   writeln (p);
end.

+ 0 -
НАСТЮШАЩЕДИНА
21 июля 2014 г., 20:48:51 (9 лет назад)

var s,s1,s2:string;
i,l:integer;
begin
readln(s);
i:=1; s1:=s; l:=length(s);
for i:=1 to l div 2 do begin
s1[i]:=s[i*2];
s1[l-i+1]:=s[(i-1)*2+1];
end;
if (l mod 2=1) then s1[l-i+1]:=s[(i-1)*2+1];
writeln(s1);
end.

+ 0 -
ERNAR
21 июля 2014 г., 21:22:22 (9 лет назад)

в чём ошибка. При вводе Hello, world! пропадает восклицательный знак и получается el,wrd lo olH

Ответить

Другие вопросы из категории

Производится двухканальная (стерео) звукозапись с частотой дискретизации 16 кГц и количеством уровней квантования 65536. Запись длится

4 минуты, ее результаты записываются в файл, сжатие данных не производится.

Нужно найти размер полученного файла.

ВНИМАНИЕ!!!

МНЕ НУЖНО ОБЬЯСНЕНИЕ РЕШЕНИЯ ПОДРОБНО!!!

Выполните операцию осложнения над двоичными числами:

а) 101010+1101
б) 1010+1010
в) 10101+111

Читайте также

Дан прямоугольный массив целых положительных чисел 10 х 20. Опишите на русском языке или на одном из языков программирования алгоритм поиска строки с

наименьшей суммой элементов. Вывести на печать номер строки и сумму ее элементов. Предполагается, что такая строка единственна.

помогите пожалуйста составить программу в Паскале!!

Натуральное число называется числом Армстронга, если сумма цифр числа, возведенных в К- ю степень( где К- количество цифр в числе) равна самому числу.

Например, 153=1³ + 5³ + 3³.
Входная строка содержит два натуральных числа- значения а и б.
Входные данные
Входная строка содержит два натуральных числа - значения а и б, разделенных пробелами. Гарантируется, что а≥б.
Выходные данные
Программа должна вывести в одну строчку все числа Армстронга на отрезке а, б, разделив их пробелами. если таких чисел нет, программа должна вывести -1.

помогите срочнооо) pascal abc 1. Развернуть обе половинки массива в обратном порядке. Считая, что массив имеет четное число элементов.

Пояснения

Из массива (1, 2, 3, 4, 5, 6, 7, 8) нужно получить массив (4, 3, 2, 1, 8, 7, 6, 5).

2. Сдвинуть все элементы массива на одну позицию влево (циклически). Первый элемент должен оказаться на месте последнего.
3. Сдвинуть все элементы массива на одну позицию вправо (циклически). Последний элемент должен оказаться на месте первого.



Вы находитесь на странице вопроса "Дана строка-предложение. Зашифровать ее, поместив вначале все символы, расположенные на четных позициях строки, а затем, в обратном порядке, все", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.