Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Решите пожалуйста!Даны три числа, если первое число положительно, то два других уменьшить в два раза, в противном случае увеличить на 3.В фри паскале

5-9 класс

на на английском языке.

Osakeop 25 сент. 2014 г., 9:04:36 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tabatadze1910
25 сент. 2014 г., 11:42:13 (9 лет назад)

var a:array [1..100] of real;
i,j,n:integer;
Begin
    n:=3;
    for i := 1 to n do
        read(a[i]);

    if a[1]>0 then
        for i:= 2 to n do a[i]:= a[i]/2;
    else
        for i:= 2 to n do a[i]:=a[i]+3;

    for i:= 1 to n do
        write(a[i],'' );
End.

 

универсальный вариант сведенный к 3 элементам

Ответить

Другие вопросы из категории

Каждая из частей изображения содержит 8 бит некоторой информации. Какая информация будет соответствовать части под номером 4, если для первой части она

равна 11111111, а в каждой последующей- значение информации в 2 раза больше, чем в предыдущей? Следует учесть, что при переполнении разрядов бит не теряется, а прибавляется к младшему разряду полученного числа.

сколько здесь треугольников?
Логический диск D имеет объем памяти 2,1 ГБ. Устройство распознавания речи воспринимает информацию с максимальной скорость 200 букв в минуту. Сколько

времени надо говорить, чтобы заполнить 80% объема памяти диска D? С объяснением, пожалуйста.

Пожалуйста помогите!

программа фриПаскаль!
Составьте программу выводящую на экран мое имя "Алиса"
Помогите,очень прошу!

Читайте также

Напишите программу, которая сравнивает два числа: 2 в степени 100 и 3 в степени 50. Программа должна выводить слово "больше", если первое число больше

второго, "равно" — если числа равны, "меньше" — если первое число меньше второго. Сами числа выводить не нужно.



Вы находитесь на странице вопроса "Решите пожалуйста!Даны три числа, если первое число положительно, то два других уменьшить в два раза, в противном случае увеличить на 3.В фри паскале", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.